worker script loads set wrong accept header

RESOLVED DUPLICATE of bug 1417463

Status

()

enhancement
P2
normal
RESOLVED DUPLICATE of bug 1417463
2 years ago
2 months ago

People

(Reporter: bkelly, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

I wrote a glitch to echo our FetchEvent attributes:

https://fetch-event-echo.glitch.me/

I noticed while using this that we set a pretty bogus accept header for worker scripts:

accept,text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

It seems completely wrong to be advertising text/html here.
Note, if you want to try the glitch, you need to manually load a worker through the web console:

  var w = new Worker('worker-location.js');
Priority: -- → P2
Per step 1.3 here we should be setting "*/*" for worker scripts:

https://fetch.spec.whatwg.org/#fetching
(Reporter)

Updated

a year ago
Depends on: 1417463
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1417463
You need to log in before you can comment on or make changes to this bug.