Cannot build mozilla-central with MozillaBuild 3.1

RESOLVED DUPLICATE of bug 1415374

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 1415374
11 days ago
11 days ago

People

(Reporter: masayuki, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox58 affected)

Details

Attachments

(1 attachment)

Created attachment 8927532 [details]
config.log

I upgraded MozillaBuild to 3.1 today, and I tried to build the latest m-c with VS 2017 after removing the old dist dir.  However, "checking for Mercurial version" failed and cannot build it.

> $ ./mach build
>  0:00.87 c:\mozilla-build\mozmake\mozmake.EXE -f client.mk MOZ_PARALLEL_BUILD=16 -s configure
>  0:03.25 Clobber not needed.
>  0:05.60 cd c:/mozilla/fx64-dbg
>  0:05.62 c:/mozilla/src/configure
>  0:05.96 Creating Python environment
>  0:12.50 New python executable in c:\mozilla\fx64-dbg\_virtualenv\Scripts\python2.7.exe
>  0:12.50 Also creating executable in c:\mozilla\fx64-dbg\_virtualenv\Scripts\python.exe
>  0:12.50 Installing setuptools, pip, wheel...done.
>  0:12.85 running build_ext
>  0:12.85
>  0:12.85 building 'psutil._psutil_windows' extension
>  0:12.85
>  0:12.85 error: INCLUDE environment variable is empty
>  0:12.85
>  0:12.85
>  0:12.85 Error processing command. Ignoring because optional. (optional:setup.py:third_party/python/psutil:build_ext:--inplace)
>  0:12.85 Error processing command. Ignoring because optional. (optional:packages.txt:comm/build/virtualenv_packages.txt)
>  0:12.85 c:\mozilla\src\python\mozbuild\mozbuild\virtualenv.py:376: UserWarning: Hacking environment to allow binary Python extensions to build. You can make this warning go away by installing Visual Studio 2008. You can download the Express Edition installer from http://go.microsoft.com/?linkid=7729279
>  0:12.85   warnings.warn('Hacking environment to allow binary Python '
>  0:12.85 Reexecuting in the virtualenv
>  0:13.19 Adding configure options from c:\Users\toybox\fx64.debug.mozconfig
>  0:13.19   --target=x86_64-pc-mingw32
>  0:13.19   --host=x86_64-pc-mingw32
>  0:13.19   --enable-debug
>  0:13.19 checking for vcs source checkout... hg
>  0:13.36 checking for a shell... C:/mozilla-build/msys/bin/sh.exe
>  0:13.55 checking for host system type... x86_64-pc-mingw32
>  0:13.71 checking for target system type... x86_64-pc-mingw32
>  0:13.75 checking for a shell... C:/mozilla-build/msys/bin/sh.exe
>  0:13.92 checking for host system type... x86_64-pc-mingw32
>  0:14.11 checking for target system type... x86_64-pc-mingw32
>  0:14.12 checking for vcs source checkout... hg
>  0:14.12 checking whether cross compiling... no
>  0:14.17 checking for the target C compiler... 'C:/PROGRA~2/MIB055~1/2017/PROFES~1/VC/Tools/MSVC/1411~1.255/bin/HostX64/x64/cl.exe'
>  0:14.24 checking whether the target C compiler can be used... yes
>  0:14.27 checking for Python 3... c:\mozilla-build\python3\python3.EXE (3.6.3)
>  0:14.29 checking for hg... c:/mozilla-build/python/Scripts/hg.exe
>  0:14.34 checking for Mercurial version...
>  0:14.34 DEBUG: <truncated - see config.log for full output>
>  0:14.34 DEBUG: |     self._load()
>  0:14.34 DEBUG: |   File "c:\mozilla-build\python\Lib\site-packages\hgdemandimport\demandimportpy2.py", line 90, in _load
>  0:14.34 DEBUG: |     mod = _hgextimport(_origimport, head, globals, locals, None, level)
>  0:14.34 DEBUG: |   File "c:\mozilla-build\python\Lib\site-packages\hgdemandimport\demandimportpy2.py", line 41, in _hgextimport
>  0:14.34 DEBUG: |     return importfunc(name, globals, *args, **kwargs)
>  0:14.34 DEBUG: |   File "c:\mozilla-build\python\Lib\site-packages\mercurial\win32.py", line 22, in <module>
>  0:14.34 DEBUG: |     _kernel32 = ctypes.windll.kernel32
>  0:14.34 DEBUG: |   File "c:\mozilla-build\python\Lib\site-packages\hgdemandimport\demandimportpy2.py", line 145, in __getattr__
>  0:14.34 DEBUG: |     self._load()
>  0:14.34 DEBUG: |   File "c:\mozilla-build\python\Lib\site-packages\hgdemandimport\demandimportpy2.py", line 90, in _load
>  0:14.34 DEBUG: |     mod = _hgextimport(_origimport, head, globals, locals, None, level)
>  0:14.34 DEBUG: |   File "c:\mozilla-build\python\Lib\site-packages\hgdemandimport\demandimportpy2.py", line 41, in _hgextimport
>  0:14.34 DEBUG: |     return importfunc(name, globals, *args, **kwargs)
>  0:14.34 DEBUG: |   File "c:\mozilla-build\python\lib\ctypes\__init__.py", line 7, in <module>
>  0:14.34 DEBUG: |     from _ctypes import Union, Structure, Array
>  0:14.34 DEBUG: |   File "c:\mozilla-build\python\Lib\site-packages\hgdemandimport\demandimportpy2.py", line 268, in _demandimport
>  0:14.34 DEBUG: |     mod = _hgextimport(_origimport, name, globals, locals)
>  0:14.34 DEBUG: |   File "c:\mozilla-build\python\Lib\site-packages\hgdemandimport\demandimportpy2.py", line 41, in _hgextimport
>  0:14.34 DEBUG: |     return importfunc(name, globals, *args, **kwargs)
>  0:14.34 DEBUG: | ImportError: DLL load failed: The specified procedure could not be found.
>  0:14.34 ERROR: Command `c:/mozilla-build/python/Scripts/hg.exe --version` failed with exit status 1.
>  0:14.35 *** Fix above errors and then restart with\
>  0:14.35                "c:/mozilla-build/mozmake/mozmake.EXE -f client.mk build"
>  0:14.37 mozmake.EXE: *** [client.mk:250: configure] Error 1

My environment is Win10-ja, Creators Update, and both VS 2015 and VS 2017 are installed.

> $ which hg
> /c/mozilla-build/python/Scripts/hg
> $ hg --version
> Mercurial Distributed SCM (version 4.4.1)
> (see https://mercurial-scm.org for more information)
> 
> Copyright (C) 2005-2017 Matt Mackall and others
> This is free software; see the source for copying conditions. There is NO
> warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
If I run it with full path (even either it starts "c:/" or "/c/"), I see same error.

And I can build m-c after I downgraded MozillaBuild to 3.0.
Oops, I found same bug.
Status: NEW → RESOLVED
Last Resolved: 11 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1415374
You need to log in before you can comment on or make changes to this bug.