Closed Bug 1416488 Opened 4 years ago Closed 4 years ago

Attempting to create a DataTransfer object using new DataTransfer() throws TypeError

Categories

(Core :: DOM: Copy & Paste and Drag & Drop, defect)

57 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1351193

People

(Reporter: guest271314, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/62.0.3202.75 Chrome/62.0.3202.75 Safari/537.36

Steps to reproduce:

let dt = new DataTransfer()


Actual results:

TypeError: Illegal constructor.


Expected results:

Create a new DataTransfer object 

dataTransfer = new DataTransfer()
Creates a new DataTransfer object with an empty drag data store.

Reference https://html.spec.whatwg.org/#the-datatransfer-interface
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1351193
You need to log in before you can comment on or make changes to this bug.