In addition to browser.tabs.loadBookmarksInTabs, support loading bookmarks in current tab by middle click

RESOLVED DUPLICATE of bug 1397372

Status

()

defect
P5
normal
RESOLVED DUPLICATE of bug 1397372
a year ago
a year ago

People

(Reporter: yurivkhan, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [photon-structure][triage])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171109183137

Steps to reproduce:

1. In about:config, make sure browser.tabs.loadBookmarksInTabs is set to true.
2. Click the Bookmarks Menu button or the Bookmarks item in the main menu.
3. Click a bookmark. Observe that it opens in a new tab, as specified by the preference in step 1.
4. Repeat step 2.
5. Middle-click a bookmark.


Actual results:

It also opens in a new tab.


Expected results:

It should open in the currently active tab.
Component: Untriaged → WebExtensions: Frontend
Product: Firefox → Toolkit
This has nothing to do with WebExtensions. I think the pref name staring with browser.tabs is what caused it to be filed under WebExtensions. This relates to bookmarks in Firefox. I'm not sure where it should be filed, but maybe Kohei has an idea.
Component: WebExtensions: Frontend → Untriaged
Flags: needinfo?(kohei.yoshino)
Product: Toolkit → Firefox
Oops, sorry, I've confused the preference name with something from the WebExtensions API.
Component: Untriaged → Bookmarks & History
Flags: needinfo?(kohei.yoshino)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [photon-structure][triage]
Priority: -- → P5
(Reporter)

Comment 4

a year ago
I found bug 1397372 that requests the same change as I did here and has objections. Should I (may I) introduce a second preference, as suggested in bug 1397372, comment 3?
(Reporter)

Updated

a year ago
Summary: browser.tabs.loadBookmarksInTabs: Middle click should load in current tab → In addition to browser.tabs.loadBookmarksInTabs, support loading bookmarks in current tab by middle click
(Reporter)

Comment 5

a year ago
This patch adds a separate preference that controls how bookmarks open on middle click. Together with loadBookmarksInTabs, four behaviors are possible:

* both false: always load in current tab
* both true: always load in a new tab
* loadBookmarksInTabs=false, loadBookmarksInTabs.middleclick=true (default): load in a new tab on middle click only
* loadBookmarksInTabs=true, loadBookmarksInTabs.middleclick=false: load in a new tab on left click only
Attachment #8933732 - Attachment is obsolete: true
Attachment #8933732 - Flags: review?(mak77)
Attachment #8933880 - Flags: review?(mak77)
Comment on attachment 8933880 [details] [diff] [review]
Add browser.tabs.loadBookmarksInTabs.middleclick

Review of attachment 8933880 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Yuri Khan from comment #5)
> This patch adds a separate preference that controls how bookmarks open on
> middle click. Together with loadBookmarksInTabs, four behaviors are possible:

This is exactly why I don't think adding a pref is a good idea, it opens too many possible edge-cases. Each of them will need a test and future maintenance, plus it complicate user support.
I'd probably be fine to invert middle click behavior by default if loadBookmarksInTabs is set, without any pref.
Attachment #8933880 - Flags: review?(mak77) → review-
(Reporter)

Comment 7

a year ago
(In reply to Marco Bonardo [::mak] from comment #6)

> I'd probably be fine to invert middle click behavior by default if
> loadBookmarksInTabs is set, without any pref.

Attachment 8933732 [details] [diff] implements this. One preference, two possible behavior out of four, middle click is always different from left click.

However, that was suggested in bug 1397372 and WONTFIXed by :Gijs. How are we to proceed?

[I think Tab Mix Plus allowed three out of four: left → same, middle → new (current Firefox default); left → new, middle → new (current Firefox behavior when browser.tabs.loadBookmarksInTabs is true); left → new, middle → current (the behavior I want).]
(In reply to Yuri Khan from comment #7)
> However, that was suggested in bug 1397372 and WONTFIXed by :Gijs. How are
> we to proceed?

Thank you for pointing out bug 1397372 that I was not aware of. Unfortunately 2 well estimated developers are against the change, and while I sympathize with your request, I cannot ignore that fact. An additional pref won't change anything about it, bug 1397372 is clear that we expect middle click to *always* open in a new tab, so we can't just introduce a pref to change it.

I don't see an easy way out. Effectively Right click + "open" is a plausible workaround, it's just unfortunate to be 2 clicks instead of one.
If you want to discuss the decision, presenting some points and use-cases that you think were not well evaluated, you are free to start a thread in the firefox-dev mailing list and hopefully someone may re-evaluate.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1397372
You need to log in before you can comment on or make changes to this bug.