Closed Bug 1416618 Opened 3 years ago Closed 3 years ago

Cannot show short date format (yy/MM/dd'('ddd')') correctly

Categories

(Core :: Internationalization, defect, P3)

Unspecified
Windows
defect

Tracking

()

VERIFIED FIXED
mozilla59
Tracking Status
firefox57 --- wontfix
firefox58 --- verified
firefox59 --- verified

People

(Reporter: m_kato, Assigned: m_kato)

Details

Attachments

(2 files)

When format is Japanese on [Region and Language] - [Formats] of Control Panel, it has (yy/MM/dd'('ddd')' for 17/11/13(月) (ddd is short weekly name).

But format shows ddd as date like 17/11/13(013).
Attached image screenshot
Priority: -- → P3
Summary: Cannot show short date format (yy/MM/dd'('ddd')' correctly → Cannot show short date format (yy/MM/dd'('ddd')') correctly
Assignee: nobody → m_kato
Comment on attachment 8928049 [details]
Bug 1416618 - Cannot show short date format (yy/MM/dd'('ddd')') correctly.

https://reviewboard.mozilla.org/r/199278/#review204436

Oops!  We should probably consider this for uplift to 58.
Attachment #8928049 - Flags: review?(jfkthame) → review+
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/26b0f3f9fca1
Cannot show short date format (yy/MM/dd'('ddd')') correctly. r=jfkthame
https://hg.mozilla.org/mozilla-central/rev/26b0f3f9fca1
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Comment on attachment 8928049 [details]
Bug 1416618 - Cannot show short date format (yy/MM/dd'('ddd')') correctly.

Approval Request Comment
[Feature/Bug causing the regression]:
bug 1301640 and bug 1308329

[User impact if declined]:
When user selects short data format like yy/MM/dd'('ddd')' on OS's preference, "ddd" shows day unfortunately.  Correct should be short name of a day of week.  This occurs on file:/// and etc.

[Is this code covered by automated tests?]:
No

[Has the fix been verified in Nightly?]:
Yes

[Needs manual test from QE? If yes, steps to reproduce]: 
Yes if possible.

- Step
1. Open [Control Panel]
2. [Clock, Language, and Region] - [Region and Language] - [Formats]
3. Select Format: to "Japanese (Japan)" and Short date: yy/MM/dd'('ddd')', then apply [OK]
4. Launch Firefox
5. Navigate to file:///c:/

- Expected result
Date format of each file is like 17/11/16 (Thr), not 17/11/16 (016)

[List of other uplifts needed for the feature/fix]:
Nothing

[Is the change risky?]:
Low

[Why is the change risky/not risky?]:
Set correct iterator to search string.

[String changes made/needed]:
N/A
Attachment #8928049 - Flags: approval-mozilla-beta?
Hi Brindusa, could you help find someone to verify if this issue was fixed as expected on the latest Nightly build? Thanks!
Flags: needinfo?(brindusa.tot)
Build ID: 20171116100106
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

Verified as fixed on Firefox Nightly 59.0a1 on Windows 7 x 64.
I couldn't verify it on Windows 10 because I couldn't find short date format like the one indicated above (yy/MM/dd'('ddd')).
Flags: needinfo?(brindusa.tot)
Comment on attachment 8928049 [details]
Bug 1416618 - Cannot show short date format (yy/MM/dd'('ddd')') correctly.

Fix the date format and was verified. Beta58+.
Attachment #8928049 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Build ID: 20171120142222
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/58.0

Verified as fixed on Firefox 58.0b5 on Windows 7 x 64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.