Closed Bug 1417336 Opened 2 years ago Closed 2 years ago

[Form Autofill] Enable credit card autofill by default on beta build

Categories

(Toolkit :: Form Autofill, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla59
Tracking Status
firefox58 --- verified
firefox59 --- verified

People

(Reporter: lchang, Assigned: lchang)

References

(Blocks 1 open bug)

Details

(Whiteboard: [form autofill:MVP])

Attachments

(1 file)

We are going to test Credit Card Autofill on Fx58 beta 5. Let's enable it by default.

Note that the feature is still restricted to the users who use en-US build and are located in the US.
Comment on attachment 8928441 [details]
Bug 1417336 - [Form Autofill] Enable credit card autofill by default on beta build.

https://reviewboard.mozilla.org/r/199696/#review205722
Attachment #8928441 - Flags: review?(schung) → review+
Pushed by lchang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0a6366334926
[Form Autofill] Enable credit card autofill by default on beta build. r=steveck
https://hg.mozilla.org/mozilla-central/rev/0a6366334926
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Comment on attachment 8928441 [details]
Bug 1417336 - [Form Autofill] Enable credit card autofill by default on beta build.

Approval Request Comment
[Feature/Bug causing the regression]:
Feature: Credit Card Autofill. We'd like to enable it on Fx58 beta 5 for testing.

[User impact if declined]:
Beta users won't see the feature.

[Is this code covered by automated tests?]:
Not necessary. It only flipped a pref.

[Has the fix been verified in Nightly?]:
No since it doesn't actually affect nightly.

[Needs manual test from QE? If yes, steps to reproduce]:
Yes. Steps on beta:

0. Change the pref "extensions.formautofill.available" to "on" via "about:config" if you're neither using en-US build nor located in the US.

1. Open Preferences and go to "Privacy & Security" panel.
2. Check if "Autofill Credit Card" exists under "Forms & Passwords" section.

[List of other uplifts needed for the feature/fix]:
N/A

[Is the change risky?]:
No.

[Why is the change risky/not risky?]:
It just changed the default value of the pref "extensions.formautofill.creditCards.available" on the beta build.

[String changes made/needed]:
N/A
Attachment #8928441 - Flags: approval-mozilla-beta?
Comment on attachment 8928441 [details]
Bug 1417336 - [Form Autofill] Enable credit card autofill by default on beta build.

Enable credit card form autofill in Beta58. Beta58+.
Attachment #8928441 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Contact: gasofie
Verified as fixed with 59.0a1 and 580b5, the pref extensions.formautofill.creditCards.available is set by default to "true", saved credit cards are available under Preferences on beta after extensions.formautofill.available pref is set to "on". 

Verified on Ubuntu 14.4, WIndows 10x64 and MacOS 10.12.6
You need to log in before you can comment on or make changes to this bug.