If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

copy and paste for bulleted items does not work correctly

VERIFIED DUPLICATE of bug 78676

Status

()

Core
Serializers
VERIFIED DUPLICATE of bug 78676
16 years ago
16 years ago

People

(Reporter: Neil Becker, Assigned: harishd)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
If I drag from right to left on one of the bulleted items, for example:
virtual void setCheckable( bool )
, and then I paste it into a text application, it produces this pasted text
(starting after the begin and before the end)
---------begin-------
#
virtual void setCheckable ( bool )
-------end---------

What I'm trying to do is simply copy that one line and be able to paste it into
my code for QT, but instead it puts in the # and/or * sometimes (depending on
how deep the list is).  I think if only one line is being selected, it should
just copy the letters I selected.  This is the behaviour I get from other browsers.

I do however like when for instance, you select a large amount of text in a
bulleted list several levels deep, that it adds those *'s and #'s, but the
linebreak between the # and the text is annoying.

I'm not sure if I put this into the correct component (sorry), it might also
happen in mail too on html messages with bullets, though I can't confirm that.

The behaviour I got from copying and pasting large lists is:
#
int insertItem ( const QString & text, QPopupMenu * popup, int id = -1, int
index = -1 )
#
int insertItem ( const QIconSet & icon, const QString & text, QPopupMenu *
popup, int id = -1, int index = -1 )
#
int insertItem ( const QPixmap & pixmap, int id = -1, int index = -1 )
#
int insertItem ( const QIconSet & icon, const QPixmap & pixmap, int id = -1, int
index = -1 )
#

the behaviour I would have expected is:
* int insertItem ( const QString & text, QPopupMenu * popup, int id = -1, int
index = -1 )
* int insertItem ( const QIconSet & icon, const QString & text, QPopupMenu *
popup, int id = -1, int index = -1 )
* int insertItem ( const QPixmap & pixmap, int id = -1, int index = -1 )
* int insertItem ( const QIconSet & icon, const QPixmap & pixmap, int id = -1,
int index = -1 )

(without the # or * at the end)
this is when you select multiple full lines in that document.

hope you can help!
thanks

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 78676 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.