Closed Bug 1417425 Opened 5 years ago Closed 5 years ago

Crash in java.io.FileNotFoundException: /data/user/0/org.mozilla.firefox/files/fxa.account.json (No such file or directory) at java.io.FileInputStream.open(Native Method)

Categories

(Firefox for Android Graveyard :: Firefox Accounts, defect, P2)

Firefox 57
Unspecified
Android
defect

Tracking

(firefox57 wontfix, firefox58 fixed)

RESOLVED DUPLICATE of bug 1403787
Tracking Status
firefox57 --- wontfix
firefox58 --- fixed

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-36c91db6-4fd0-405f-bcce-4ba0b0171115.
=============================================================

Seen while looking at 57 crash stats: https://mzl.la/2ijU3OC. New crash in 57 which affects APIs 24/25. No useful comments.

Top 10 frames of crashing thread:

0 libxul.so mozilla::jni::NativeStub<mozilla::java::GeckoAppShell::ReportJavaCrash_t, GeckoAppShellSupport, mozilla::jni::Args<const mozilla::jni::Ref<mozilla::jni::TypedObject<_jthrowable*>, _jthrowable*>&, const mozilla::jni::StringParam&> >::Wrap<GeckoAppShellSupport::ReportJavaCrash> widget/android/nsAppShell.cpp:277
1 base.odex base.odex@0x951d15 
2 dalvik-LinearAlloc_3703_3703 (deleted) dalvik-LinearAlloc_3703_3703 @0x58aa 
3 dalvik-main space_3703_3703 (deleted) dalvik-main space_3703_3703 @0xd581e 
4 dalvik-main space_3703_3703 (deleted) dalvik-main space_3703_3703 @0x24227e 
5 dalvik-main space_3703_3703 (deleted) dalvik-main space_3703_3703 @0x4a4ffe 
6 dalvik-main space_3703_3703 (deleted) dalvik-main space_3703_3703 @0x3d4c9e 
7 libart.so libart.so@0xa9bc1 
8 dalvik-main space_3703_3703 (deleted) dalvik-main space_3703_3703 @0x24227e 
9 dalvik-main space_3703_3703 (deleted) dalvik-main space_3703_3703 @0x4a4ffe 

=============================================================
Top crash in 57. Please triage.
Flags: needinfo?(gkruglov)
Priority: -- → P2
Probably a duplicate of bug 1403787.
Seems like it is. I'm surprised that Bug 1403787 didn't land yet :-( It slipped off the radar.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(gkruglov)
Resolution: --- → DUPLICATE
Duplicate of bug: 1403787
There seems to be two sets of stacktraces here. One is what Bug 1403787 addresses, and another is this:

java.io.FileNotFoundException: /data/user/0/org.mozilla.firefox/files/fxa.account.json (No such file or directory)
	at java.io.FileInputStream.open(Native Method)
	at java.io.FileInputStream.<init>(FileInputStream.java:146)
	at android.app.ContextImpl.openFileInput(ContextImpl.java:488)
	at android.content.ContextWrapper.openFileInput(ContextWrapper.java:186)
	at org.mozilla.gecko.sync.Utils.readFile(Utils.java:487)
	at org.mozilla.gecko.fxa.authenticator.AccountPickler.unpickleParams(AccountPickler.java:166)
	at org.mozilla.gecko.fxa.authenticator.AndroidFxAccount.getAccountUID(AndroidFxAccount.java:218)
	at org.mozilla.gecko.fxa.authenticator.AndroidFxAccount.getSyncPrefs(AndroidFxAccount.java:451)
	at org.mozilla.gecko.fxa.activities.FxAccountStatusFragment.refresh(FxAccountStatusFragment.java:429)
	at org.mozilla.gecko.fxa.activities.FxAccountStatusActivity.onResume(FxAccountStatusActivity.java:95)
	at android.app.Instrumentation.callActivityOnResume(Instrumentation.java:1270)
	at android.app.Activity.performResume(Activity.java:6870)
	at android.app.ActivityThread.performResumeActivity(ActivityThread.java:3390)
	at android.app.ActivityThread.handleResumeActivity(ActivityThread.java:3453)
	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2726)

Install age is mostly just around a minute, and uptime is close to "startup"; to me indicates that this is a one-time crash, which makes sense - once that file is created, we won't run into these problems again, and this top crasher will "go away".

As to why this actually happens... a tautological explanation is that we're still racing between pickle file creation and loading the sync prefs activity. We now pickle immediately on account creation, but apparently that's not enough.
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.