Closed Bug 1417599 Opened 2 years ago Closed 2 years ago

Crash in nsStyleDisplay const* nsStyleContext::DoGetStyleDisplay<T>

Categories

(Core :: CSS Parsing and Computation, defect, critical)

Unspecified
All
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1417411
Tracking Status
firefox57 --- unaffected
firefox59 --- affected

People

(Reporter: yoasif, Unassigned)

Details

(Keywords: crash, nightly-community)

Crash Data

This bug was filed from the Socorro interface and is
report bp-a6188520-0103-42f3-b5a8-4a3be0171115.
=============================================================

Top 10 frames of crashing thread:

0 XUL nsStyleDisplay const* nsStyleContext::DoGetStyleDisplay&lt;true&gt; layout/style/nsStyleContext.h:206
1 XUL nsDisplayTransform::ComputePerspectiveMatrix obj-firefox/dist/include/nsStyleStructList.h:100
2 XUL nsDisplayPerspective::CreateWebRenderCommands layout/painting/nsDisplayList.cpp:8945
3 XUL mozilla::layers::WebRenderCommandBuilder::CreateWebRenderCommandsFromDisplayList gfx/layers/wr/WebRenderCommandBuilder.cpp:222
4 XUL &lt;name omitted&gt; layout/painting/nsDisplayList.cpp:6164
5 XUL nsDisplayTransform::CreateWebRenderCommands layout/painting/nsDisplayList.cpp:8366
6 XUL mozilla::layers::WebRenderCommandBuilder::CreateWebRenderCommandsFromDisplayList gfx/layers/wr/WebRenderCommandBuilder.cpp:222
7 XUL &lt;name omitted&gt; layout/painting/nsDisplayList.cpp:6164
8 XUL nsDisplayTransform::CreateWebRenderCommands layout/painting/nsDisplayList.cpp:8366
9 XUL mozilla::layers::WebRenderCommandBuilder::CreateWebRenderCommandsFromDisplayList gfx/layers/wr/WebRenderCommandBuilder.cpp:222

=============================================================


I experienced this issue today. 

18 crashes in the last week across OSes.
Whiteboard: [wr-mvp] [triage]
This happens without webrender as well: https://crash-stats.mozilla.com/report/index/916a4514-cdea-4140-bebd-aa6a60171116
Component: Graphics: WebRender → CSS Parsing and Computation
Priority: P2 → --
There are STR to reproduce this in bug 1417411
Blocks: 1417411
No longer blocks: stage-wr-nightly
No longer blocks: 1417411
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1417411
You need to log in before you can comment on or make changes to this bug.