Closed Bug 1417691 Opened 3 years ago Closed 3 years ago

Single word containing period should not always be handled as URL

Categories

(Firefox :: Address Bar, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1080682

People

(Reporter: jesskay, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171115100050

Steps to reproduce:

Enter input in the combined address/search bar that contains a period, but no spaces (example: "node.js")


Actual results:

Firefox attempts to resolve node.js as a URL, which it fails to access.


Expected results:

Firefox should have some way to be told it should interpret such inputs as searches. (I understand that the behaviour in question can't reasonably be changed globally, but some option to by default prefer search over URL resolution would be very welcome).

Alternatively, for the specific case in my example, Firefox should be aware that .js as a TLD is not likely to ever be valid on the general internet (it's two characters long, which is reserved for countries), and treat it as a search by default.
Component: Untriaged → Address Bar
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1080682
You need to log in before you can comment on or make changes to this bug.