Closed Bug 1417776 Opened 4 years ago Closed 11 months ago

Enabling "Reduce screen motion" on macOS should set toolkit.cosmeticAnimations.enabled;false

Categories

(Core :: Widget: Cocoa, defect, P2)

Unspecified
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1478597
Tracking Status
firefox57 --- affected
firefox58 --- affected
firefox59 --- affected

People

(Reporter: yoasif, Unassigned)

References

Details

(Keywords: nightly-community, Whiteboard: [tpi:+])

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171115100050

Steps to reproduce:

1. Enable "Reduce screen motion" in macOS https://support.apple.com/kb/PH25204?locale=en_US
2. Start Firefox


Actual results:

toolkit.cosmeticAnimations.enabled is not made false.


Expected results:

toolkit.cosmeticAnimations.enabled should be false. Ideally, this should be a user facing preference as well, with options of "Enabled, Disabled and Use System Preferences". 

It would be nice if this weren't a boolean, or if there were a new setting like "toolkit.cosmeticAnimations.enabled.system" that controlled the "Use System Preferences" setting.
OS: Unspecified → Mac OS X
Component: Untriaged → General
Component: General → Widget: Cocoa
Product: Firefox → Core
Priority: -- → P2
Whiteboard: [tpi:+]
Depends on: 1352069
Depends on: 1475462
I think what we should do for this is to check prefers-reduced-motion media query in the case where we create animations in script and adding alternative styles, instead of setting toolkit.cosmeticAnimations.enabled and checking the pref once we support prefers-reduced-motion on all platforms.

Dão, is this a dupe of bug 1478597? I don't want to keep this open if it is already resolved. Thanks!

Flags: needinfo?(dao+bmo)
Status: NEW → RESOLVED
Closed: 11 months ago
Flags: needinfo?(dao+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1478597
You need to log in before you can comment on or make changes to this bug.