Closed Bug 1418314 Opened 2 years ago Closed 2 years ago

"Learn More..." link for Shockwave Flash plugin not working

Categories

(Toolkit :: Add-ons Manager, defect, P3)

59 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- verified
firefox60 --- verified

People

(Reporter: marius.santa, Assigned: mossop)

References

Details

(Keywords: regression)

Attachments

(2 files)

[Affected versions]:
Firefox 59.0a1 (20171116220410)

[Affected platforms]:
Windows 10 64-bit
MacOS Sierra 10.13
Ubuntu 16.04 32-bit


[Steps to reproduce]:
1.Launch Firefox with a clean profile.
2.Install any addon.
3.Go to "about:addons>Extensions".
4.Click on the "More" button for any extension.
5.Go to "Plugins>Shockwave Flash(More button).
6.Click on "Learn More...".


[Expected Results]:
The user is redirected to "https://support.mozilla.org/en-US/kb/flash-blocklists".

[Actual Results]:
Nothing happens.


[Additional notes]:
I am not sure if steps 2 and 3 are relevant to the bug reproduction but it reproduced 100% after using them.
Gif of issue attached.
Summary: "Learn More..." not working → "Learn More..." link for Shockwave Flash plugin not working
Mossop, I think this could have been the changes to toolkit/mozapps/extensions/content/pluginPrefs.xul in bug 1414406. If we don't want to link it up, we could just remove the link. Seems like a useful SUMO page though.
Flags: needinfo?(dtownsend)
Priority: -- → P3
Argh, apparently I missed this part.
Assignee: nobody → dtownsend
Flags: needinfo?(dtownsend)
Duplicate of this bug: 1434321
Dave, is there anything left to do here?
Flags: needinfo?(dtownsend)
(In reply to Andrew Overholt [:overholt] from comment #4)
> Dave, is there anything left to do here?

Yes, it probably needs to be fixed but I haven't had much chance to work on it so far.
Flags: needinfo?(dtownsend)
Ok, my question originated because this bug is marked as a regression in 59 and we track those more closely than regular bugs :)
Comment on attachment 8947230 [details]
Bug 1418314: Make the learn more links in plugin details work properly again.

https://reviewboard.mozilla.org/r/216982/#review222840
Attachment #8947230 - Flags: review?(aswan) → review+
Pushed by dtownsend@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/101ece463c39
Make the learn more links in plugin details work properly again. r=aswan
https://hg.mozilla.org/mozilla-central/rev/101ece463c39
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Comment on attachment 8947230 [details]
Bug 1418314: Make the learn more links in plugin details work properly again.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1414406
[User impact if declined]: Learn more links in the details of Flash won't work.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Simple addition of a href attribute to the existing links
[String changes made/needed]: None
Attachment #8947230 - Flags: approval-mozilla-beta?
Comment on attachment 8947230 [details]
Bug 1418314: Make the learn more links in plugin details work properly again.

Small css fix, fixes a regression, let's take it for 59 beta 7.
Attachment #8947230 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [good first verify]
I have Reproduced this bug with Firefox Nightly 60.0a1 (2018-02-06)on Windows 7, (32-bit)

Steps to reproduce:

1)Launched Firefox with New profile
2)Go to "about:addons>Extensions".
3)Click on the "More" button for any extension (for example: I tried Webdeveloper), 
It Shows the Information regarding webdeveloper extension.
4)Then I Gone to "Plugins>Shockwave Flash(More button)" 
5)I just Clicked on Learn More button...

Actual Results: 

After Clicking on "Learn more Button", it is redirected to "https://support.mozilla.org/en-US/kb/flash-blocklists" in a new tab.

Status: Fixed & Verified

FirefoxVersion:60.0a1
Build ID: 20180206100151
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:60.0) Gecko/20100101 Firefox/60.0
OS: Windows_NT 6.1

[bugday-20180207]
I reproduced this issue using Fx 59.0b5, on Windows 10 x64.
I can confirm this issue is fixed, I verified using Fx 59.0b7, and Fx 60.0a1 (build ID: 20180206220102), on Windows 10 x64, Ubuntu 14.04 LTS x64 and mac OS X 10.11.5.

Cheers!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.