Status

enhancement
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: aki, Assigned: aki)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

In theory this should be super simple, but I'm taking a refactor along with it.
Part 1: add devedition relpro flavors; rename shipping-phases to build/promote/push/ship .

I'm going to attempt part 2: list kinds to *exclude* from previous graphs, rather than explicitly naming previous_graph_kinds. If this doesn't work I'll just leave this patch.

This patch will require a braindump patch as well; incoming.
Attachment #8929668 - Flags: feedback?(rail)
This should land in braindump when the devedition patch lands on maple.
This should simplify our relpro maintenance as we add kinds.

If we think these look good, let's land these two patches on maple and the braindump patch in braindump. I avoided landing right before PTO because I didn't want to bitrot + break everything and then disappear.
Attachment #8929675 - Flags: feedback?(rail)
Blocks: 1397773
Comment on attachment 8929675 [details] [diff] [review]
rebuild_kinds.patch

Review of attachment 8929675 [details] [diff] [review]:
-----------------------------------------------------------------

::: taskcluster/taskgraph/actions/release_promotion.py
@@ +114,5 @@
>                  'title': 'target task method',
>                  'description': ('Optional: the target task method to use to generate '
>                                  'the new graph.'),
>              },
> +            'rebuild_kinds': {

Hmm, "rebuild" sounds imperative and makes me think that you list the kinds you want to force-rebuild here, but IIRC it does the opposite. I wonder if "reuse_kinds" would be better.
Attachment #8929675 - Flags: feedback?(rail) → feedback+
(In reply to Rail Aliiev [:rail] ⌚️ET from comment #5)
> Hmm, "rebuild" sounds imperative and makes me think that you list the kinds
> you want to force-rebuild here, but IIRC it does the opposite. I wonder if
> "reuse_kinds" would be better.

I'm open to a rename, but "reuse_kinds" sounds like we're going to reuse them from the previous graph. rebuild_kinds are the kinds we want to run in the current phase, even if they ran previously.
Ah, then nevermnind. For some reason I thought that we don't rebuild them.
I think promote_{product} is fine. I'm adding more relpromo flavors to trigger_action. I'm not going to remove publish_fennec until the rename has been uplifted or rides the trains.
Attachment #8932605 - Flags: review?(rail)
Attachment #8932605 - Flags: review?(rail) → review+
Sent email.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.