Closed Bug 1418561 Opened 2 years ago Closed 2 years ago

Zoom percentage in hamburger menu has dark text on dark background when using dark GTK3 desktop theme

Categories

(Firefox :: Toolbars and Customization, defect)

57 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1379725

People

(Reporter: krinkodot22, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20100101

Steps to reproduce:

Similar to bug 1418231, using a dark GTK3 desktop theme such as Adwaita Dark causes the zoom percentage label in the hamburger menu to appear with an illegible colour scheme.


Actual results:

The text and background of the zoom percentage label are both white. Hovering the mouse over the label darkens the background somewhat, making the text legible.


Expected results:

The label should have either dark text on a light background, or light text on a dark background.
Looks like the background color comes from https://hg.mozilla.org/mozilla-central/rev/cb9964c00980#l5.153
Moving component to find out from where the foreground color comes.
Guessing this is a regression from that changeset.  (From the switch to photon, really.)
Blocks: 1354105
Component: Widget: Gtk → Toolbars and Customization
Keywords: regression
Product: Core → Firefox
I think this is a duplicate of bug 1379725.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1379725
You need to log in before you can comment on or make changes to this bug.