Closed Bug 1418900 Opened 2 years ago Closed 7 months ago

Error when running ./mach bootstrap

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1477487

People

(Reporter: cnevinchen, Unassigned)

Details

I got below error when running bootstrap ( either it's artifact or full build)





We are now installing the following Android packages:
platform-tools
build-tools;25.0.3
platforms;android-23
extras;android;m2repository
extras;google;m2repository
emulator

You may be prompted to agree to the Android license. You may see some of
output as packages are downloaded and installed.

Exception in thread "main" java.lang.NoClassDefFoundError: javax/xml/bind/annotation/XmlSchema
	at com.android.repository.api.SchemaModule$SchemaModuleVersion.<init>(SchemaModule.java:156)
	at com.android.repository.api.SchemaModule.<init>(SchemaModule.java:75)
	at com.android.sdklib.repository.AndroidSdkHandler.<clinit>(AndroidSdkHandler.java:81)
	at com.android.sdklib.tool.SdkManagerCli.main(SdkManagerCli.java:117)
	at com.android.sdklib.tool.SdkManagerCli.main(SdkManagerCli.java:93)
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.annotation.XmlSchema
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:582)
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:185)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:496)
	... 5 more
Error running mach:

    ['bootstrap']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

CalledProcessError: Command '['/Users/nevin/.mozbuild/android-sdk-macosx/tools/bin/sdkmanager', '--package_file=/Users/nevin/Desktop/mozilla-central/python/mozboot/mozboot/android-packages.txt']' returned non-zero exit status 1

  File "/Users/nevin/Desktop/mozilla-central/python/mozboot/mozboot/mach_commands.py", line 32, in bootstrap
    bootstrapper.bootstrap()
  File "/Users/nevin/Desktop/mozilla-central/python/mozboot/mozboot/bootstrap.py", line 296, in bootstrap
    getattr(self.instance, 'install_%s_packages' % application)()
  File "/Users/nevin/Desktop/mozilla-central/python/mozboot/mozboot/osx.py", line 202, in install_mobile_android_packages
    getattr(self, 'ensure_%s_mobile_android_packages' % self.package_manager)()
  File "/Users/nevin/Desktop/mozilla-central/python/mozboot/mozboot/osx.py", line 366, in ensure_homebrew_mobile_android_packages
    no_interactive=self.no_interactive)
  File "/Users/nevin/Desktop/mozilla-central/python/mozboot/mozboot/android.py", line 180, in ensure_android
    ensure_android_packages(sdkmanager_tool=sdkmanager_tool, no_interactive=no_interactive)
  File "/Users/nevin/Desktop/mozilla-central/python/mozboot/mozboot/android.py", line 233, in ensure_android_packages
    subprocess.check_call(args)
  File "/usr/local/Cellar/python/2.7.14/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 186, in check_call
    raise CalledProcessError(retcode, cmd)
Just found out.
In the latest bootstrap code use Java 9 and cause this error.
(In reply to Nevin Chen [:nechen] from comment #1)
> Just found out.
> In the latest bootstrap code use Java 9 and cause this error.

Ah, yes.  Mossop saw this as well.  Are you on macOS?  The 'java' at https://searchfox.org/mozilla-central/rev/c633ffa4c4611f202ca11270dcddb7b29edddff8/python/mozboot/mozboot/osx.py#353 needs to be 'java8' now.  I can't post a patch just this minute 'cuz my HG repository is corrupt.
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: -- → P5

(In reply to Bobby Holley (:bholley) from comment #4)

This works for me, presumably because we explicitly specify java8 [1] now.

Nick, should we WFM this bug and update the docs in [2]?

Yes, done.

Status: NEW → RESOLVED
Closed: 7 months ago
Flags: needinfo?(nalexander)
Resolution: --- → DUPLICATE
Duplicate of bug: 1477487
Product: Firefox for Android → Firefox Build System
You need to log in before you can comment on or make changes to this bug.