Move E10SUtils.jsm into toolkit/

RESOLVED FIXED in Firefox 59

Status

()

enhancement
--
blocker
RESOLVED FIXED
a year ago
8 months ago

People

(Reporter: standard8, Assigned: emk)

Tracking

(Blocks 1 bug)

unspecified
mozilla59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Bug 1396172 has added support for WebExtensions. Bug 1414406 has removed support from Gecko for in-line preferences in legacy add-ons.

Therefore from 59 onwards, any extensions will need to provide a WebExtension part to display the preferences.

Unfortunately, that is currently broken, if you install a hybrid extension with a preferences part, opening up Tools -> Add-ons doesn't show the preferences. The console shows:

 Failed to load module resource:///modules/E10SUtils.jsm

If I copy the Firefox version and get that installed, then WebExtension preferences work fine.

Either we need a modified copy of it, or we need to get the one in Firefox moved to Toolkit.

Requesting tracking as this blocks extensions in 59.

Comment 1

a year ago
Mark, a few questions:
A) Can you please attach such a hybrid extension for testing and educational purposes.
   We need to know what our add-on authors need to do.
B) Can you please clarify this bug:
   1) Thunderbird needs a version of E10SUtils.jsm / or 2) to move the Firefox version into toolkit/
   1a) Either we need a modified copy of it, or 2) we need to get the one in Firefox moved to Toolkit.
   So is it possible to create a "unified" copy and place it into Toolkit?
   That would be a Core/Toolkit bug.
   How would the TB version need to be different, if at all?

I'm not sure I understand Philipp's comment from bug 139617 comment #19:
To be able to provide compat for existing add-ons using inline options we might need to resurrect those bindings in c-c and hope that the underlying xbl stuff is not removed before 59.

So maybe he plans to avoid hybrid add-ons, so to remove the need to embed a WebExtension in a legacy add-on.
Flags: needinfo?(standard8)
(Reporter)

Comment 2

a year ago
(In reply to Jorg K [Almost not working on Thunderbird (some bustage-fix only) due to non-renewal of contract] from comment #1)
> Mark, a few questions:
> A) Can you please attach such a hybrid extension for testing and educational
> purposes.
>    We need to know what our add-on authors need to do.

There's a thread on dev.apps.thunderbird, see but also I've started an experimental conversion for TB conversations here:

https://github.com/Standard8/thunderbird-conversations/commit/bed5b4ad7fc968d3115fcccf5a1ab4cfeaf1cae5

> B) Can you please clarify this bug:
>    1) Thunderbird needs a version of E10SUtils.jsm / or 2) to move the
> Firefox version into toolkit/
>    1a) Either we need a modified copy of it, or 2) we need to get the one in
> Firefox moved to Toolkit.
>    So is it possible to create a "unified" copy and place it into Toolkit?
>    That would be a Core/Toolkit bug.
>    How would the TB version need to be different, if at all?

Sorry, I can't clarify that at the moment, hence why I intentionally left it open. I only took a quick glance at E10SUtils.jsm, and really it needs in-depth fixes.

> I'm not sure I understand Philipp's comment from bug 139617 comment #19:
> To be able to provide compat for existing add-ons using inline options we
> might need to resurrect those bindings in c-c and hope that the underlying
> xbl stuff is not removed before 59.
> 
> So maybe he plans to avoid hybrid add-ons, so to remove the need to embed a
> WebExtension in a legacy add-on.

I've added some notes in bug 1396172 - personally I think if Thunderbird is sticking with Gecko for the near-mid future, I think it may have to think about hybrid extensions regardless, to avoid having to maintain the full legacy add-on code.
Flags: needinfo?(standard8)

Updated

a year ago
Severity: normal → blocker

Updated

a year ago
Blocks: 1419145
It (In reply to Mark Banner (:standard8) from comment #0)
> Bug 1396172 has added support for WebExtensions. Bug 1414406 has removed
> support from Gecko for in-line preferences in legacy add-ons.
> 
> Therefore from 59 onwards, any extensions will need to provide a
> WebExtension part to display the preferences.

I think I am missing something evident here: legacy add-ons with a classic non-inline XUL prefwindow for their preferences aren't affected? Add-ons affected could not use these XUL prefwindow instead?
(Assignee)

Comment 4

a year ago
Some Toolkit files depend on E10SUtils.jsm which is under browser/, which is wrong. This is a Toolkit bug.
Component: General → General
Product: Thunderbird → Toolkit
Summary: Thunderbird needs a version of E10SUtils.jsm / or to move the Firefox version into toolkit/ → Move E10SUtils.jsm into toolkit/
Comment hidden (mozreview-request)
(Assignee)

Updated

a year ago
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED

Comment 6

a year ago
Thanks for taking the bug. Does that mean that WebExtension or hybrid extensions will then be able to display their options in the Add-ons Manager again in Thunderbird? That would be nice.
(Assignee)

Comment 7

a year ago
(In reply to Jorg K (GMT+1) from comment #6)
> Thanks for taking the bug. Does that mean that WebExtension or hybrid
> extensions will then be able to display their options in the Add-ons Manager
> again in Thunderbird? That would be nice.

I believe so (also in all other XUL apps), but I only confirmed that this patch did not break Firefox. Some Thunderbird developers should verify the fix.

Comment 8

a year ago
mozreview-review
Comment on attachment 8936377 [details]
Bug 1418914 - Move E10SUtils.jsm into toolkit/.

https://reviewboard.mozilla.org/r/207106/#review213236
Attachment #8936377 - Flags: review?(dtownsend) → review+

Comment 9

a year ago
Pushed by VYV03354@nifty.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/2ae36d12890a
Move E10SUtils.jsm into toolkit/. r=mossop

Comment 10

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2ae36d12890a
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59

Updated

8 months ago
Blocks: webext-tb
No longer depends on: webext-tb
You need to log in before you can comment on or make changes to this bug.