Closed Bug 1419024 Opened 3 years ago Closed 3 years ago

Crash in mozilla::MediaDecoderStateMachine::AccurateSeekingState::OnSeekRejected

Categories

(Core :: Audio/Video: Playback, defect)

Unspecified
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1416799
Tracking Status
firefox58 --- fixed
firefox59 --- fixed

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-7e4f12d5-5723-4dbd-a0fc-8a0e00171118.
=============================================================

Seen while looking at nightly crash stats: http://bit.ly/2zlxwLz. Linux only crash which is rising in 58 beta 4.

Top 10 frames of crashing thread:

0 libxul.so mozilla::MediaDecoderStateMachine::AccurateSeekingState::OnSeekRejected dom/media/MediaDecoderStateMachine.cpp:1167
1 libxul.so mozilla::MozPromise<mozilla::media::TimeUnit, mozilla::SeekRejectValue, true>::ThenValue<mozilla::MediaDecoderStateMachine::AccurateSeekingState::DemuxerSeek> >::DoResolveOrRejectInternal xpcom/threads/MozPromise.h:520
2 libxul.so mozilla::MozPromise<mozilla::media::TimeUnit, mozilla::SeekRejectValue, true>::ThenValueBase::ResolveOrRejectRunnable::Run xpcom/threads/MozPromise.h:402
3 libxul.so mozilla::AutoTaskDispatcher::TaskGroupRunnable::Run xpcom/threads/TaskDispatcher.h:214
4 libxul.so mozilla::TaskQueue::Runner::Run 
5 libxul.so nsThreadPool::Run 
6 libxul.so nsThread::ProcessNextEvent 
7 libxul.so NS_ProcessNextEvent 
8 libxul.so mozilla::ipc::MessagePumpForNonMainThreads::Run 
9 libxul.so MessageLoop::Run 

=============================================================
Some patch has been finished reviewing and wait for landing in bug 1416799.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1416799
You need to log in before you can comment on or make changes to this bug.