Font rendering issues with Firefox 57-58

RESOLVED DUPLICATE of bug 1412090

Status

()

defect
RESOLVED DUPLICATE of bug 1412090
2 years ago
2 years ago

People

(Reporter: marcoh.huenseler+reg, Unassigned)

Tracking

58 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171121100129

Steps to reproduce:

Use openSUSE Tumbleweed on a Lenovo E530 with Intel Ivy Bridge chipset and current Mesa drivers. From glxinfo:

Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel(R) Ivybridge Mobile  (0x166)
    Version: 17.2.5
    Accelerated: yes

Upgrade Firefox from version 56 to 57 using the "Mozilla" repository on openSUSE Tumbleweed. Open any website with text.

Download Firefox 57 and 58beta packages from mozilla.org. Unzip, run firefox. Open any website with text.

Try the same steps using the packages above with a fresh profile. Try the same steps: In safe mode, with every possible hardware acceleration setting.


Actual results:

Text does not get rendered properly (see attached screenshot). It does not seem like this behavior depends on enabled hardware acceleration. It happens in Safe Mode as well.


Expected results:

Text should get rendered properly like it used to with Firefox 56 and like it is rendered using Firefox Nightly (nightly works!).
This is a result of our new sandbox feature and a font on your system that is installed in a location that gets blocked by the sandbox.

see also http://www.morbo.org/2017/11/linux-sandboxing-improvements-in.html
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1412090
You need to log in before you can comment on or make changes to this bug.