Menu bar not shown in title bar but below title bar

RESOLVED DUPLICATE of bug 1283299

Status

()

defect
RESOLVED DUPLICATE of bug 1283299
a year ago
a year ago

People

(Reporter: tmpguy, Unassigned)

Tracking

58 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171121100129

Steps to reproduce:

I did press alt key.


Actual results:

Menu bar appears at the bottom of the title buttons.


Expected results:

Menu bar should appears beside buttons in a raw.
(Reporter)

Updated

a year ago
Component: Untriaged → Menus
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

a year ago
Please provide operating system and desktop environment information.
Flags: needinfo?(tmpguy)
Summary: Native menu bar → Menu bar not shown in title bar but below title bar
(Reporter)

Comment 2

a year ago
It is ubuntu, DE is unity.
Flags: needinfo?(tmpguy)
We can't draw in the titlebar on Linux yet. Bug 1283299 is on file and being worked on to fix that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: gtktitlebar
(Reporter)

Comment 4

a year ago
Everything is ok with quantum, I've this problem with nightly 59.0a1.
Whenever widget.allow-client-side-decoration set to true and browser.tabs.drawInTitlebar set to true, too.
> We can't draw in the titlebar on Linux yet. Bug 1283299 is on file and being worked on to fix that.
You need to log in before you can comment on or make changes to this bug.