Closed Bug 1419819 Opened 4 years ago Closed 4 years ago

The Show/Hide Previous Tabs toggle button overlaps the adjacent label

Categories

(Firefox :: Session Restore, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- verified

People

(Reporter: JuliaC, Assigned: scottwu)

References

Details

(Keywords: regression)

Attachments

(2 files)

[Affected versions]:
- latest Nightly 59.0a1 (2017-11-22) 

[Affected platforms]:
- Windows 10 x64 
- Ubuntu 16.04 x86
- mac OS 10.13

[Steps to reproduce]:
1. Launch Firefox
2. Go to about:sessionrestore (or repeatedly crash Firefox in order to initiate the session restore process) 
3. Inspect the Show/Hide Previous Tabs toggle button

[Expected result]:
- The Show/Hide Previous Tabs button is properly displayed and it is functional

[Actual result]:
- The Show/Hide Previous Tabs toggle button overlaps the adjacent label (see the screenshot https://goo.gl/cmegDX)

[Regression range]:
- It seems that Bug 1413162 regressed this issue 
- Last good revision: 589acfe789d8cf8ee113baa86af29018ffb6b43c
- First bad revision: 224bb68f1fc934d9030f5b9c93407679083201c5
- Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=589acfe789d8cf8ee113baa86af29018ffb6b43c&tochange=224bb68f1fc934d9030f5b9c93407679083201c5
Scott, please take a look at this bug given the regression range points to your patch in bug 1413162. Thank you.
Flags: needinfo?(scwwu)
Thanks for bringing this to my attention. The bug is caused by adding html|button selector to the padding rules used by xul buttons. It turns out the padding rules don't play well with buttons outside of preferences, and since !important keyword is used, it's harder to override the rules.

Originally I added the selector to make sure future html dialogs in preferences would have the same button styles as XUL does. This patch removes the selector, and reverts back to styling the buttons from Form Autofill stylesheets.
Assignee: nobody → scwwu
Flags: needinfo?(scwwu)
Comment on attachment 8933203 [details]
Bug 1419819 - Remove html|button padding rule from common stylesheet.

https://reviewboard.mozilla.org/r/204128/#review209858
Attachment #8933203 - Flags: review?(jaws) → review+
Thanks. Checking it in.
Keywords: checkin-needed
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/c32c3cd8c898
Remove html|button padding rule from common stylesheet. r=jaws
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c32c3cd8c898
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Blocks: 1413162
No longer depends on: 1413162
I have reproduced this bug with Nightly 59.0a1 (2017-11-22) on Windows 8.1 , 64 Bit ! 

This bug's fix is Verified with latest Nightly!

Build   ID    20171227100314
User Agent    Mozilla/5.0 (Windows NT 6.3; WOW64; rv:59.0) Gecko/20100101 Firefox/59.0

[bugday-20171227]
Flags: in-qa-testsuite+
Marking this accordingly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.