Closed Bug 1419827 Opened 3 years ago Closed 3 years ago

moz-extension: pages should probably not be stored in history.

Categories

(Toolkit :: Places, enhancement, P2)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1314123

People

(Reporter: mak, Unassigned)

Details

(Whiteboard: [fxsearch])

I have an extension generating pages on the fly, those are registered in global history, likely they shouldn't be (we don't store about: or chrome:)

I think in the past we discussed converting the current blacklist into a whitelist.
https://searchfox.org/mozilla-central/rev/797c93d81fe446f78babf20894f0729f15f71ee6/toolkit/components/places/nsNavHistory.cpp#1171
Though it's unclear what may have more value for the user.
Whiteboard: [fxsearch]
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1314123
Thanks, you are right, and the relevant info is https://bugzilla.mozilla.org/show_bug.cgi?id=1314123#c12
"Google Chrome record and display the history for "chrome-extension://"."

so it's mostly for cross browser consistency. I sort of disagree but that's just an opinion :)
You need to log in before you can comment on or make changes to this bug.