Closed Bug 1419876 Opened 4 years ago Closed 4 years ago

Angle full-screen Present pass

Categories

(Core :: Graphics: WebRender, enhancement, P1)

x86_64
Windows 10
enhancement

Tracking

()

RESOLVED FIXED
Tracking Status
firefox59 --- affected

People

(Reporter: kvark, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [wr-reserve])

Attachments

(1 file)

Attached image 01-present-quad.png
RenderDoc captures show that (when running MotionMark) we are rendering into an off-screen texture, which gets blit to the swapchain right before Present call. This is likely coming from Angle, and I can see that the image is flipped during this flip (may be the reason for a flip in the first place?). It takes surprisingly large amount of GPU time, although I suspect RenderDoc timing just going crazy at this spot...

Anyhow, there should be absolutely no need for this full-screen blit.
Whiteboard: [wr-mvp] [triage]
Whiteboard: [wr-mvp] [triage] → [wr-mvp] [triage][wr-reserve-candidate]
Priority: -- → P3
Whiteboard: [wr-mvp] [triage][wr-reserve-candidate] → [wr-reserve]
Glenn found this wonderful link: https://github.com/Microsoft/angle/wiki/Getting-Good-Performance-From-ANGLE#--use-our-render-to-backbuffer-flags
Basically, Microsoft has a patch for disabling this extra pass. We should definitely use it!
(In reply to Dzmitry Malyshau [:kvark] from comment #1)
> Glenn found this wonderful link:
> https://github.com/Microsoft/angle/wiki/Getting-Good-Performance-From-ANGLE#-
> -use-our-render-to-backbuffer-flags
> Basically, Microsoft has a patch for disabling this extra pass. We should
> definitely use it!

Created Bug 1421199 for enabling EGL_EXPERIMENTAL_PRESENT_PATH_FAST_ANGLE usage.
Depends on: 1421199
Confirmed to be fixed by Sotaro's changes.
Thank you!
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Priority: P3 → P1
You need to log in before you can comment on or make changes to this bug.