preformatted text: white space compressed and font not monospace when printing

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Bob Fox, Assigned: rods (gone))

Tracking

({pp})

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

Preformatted text occurs between <pre> and </pre>, all within <td> </td>.  It
displays as expected on screen and in print preview (monospace font with extra
spaces preserved).  When printed, the font is not monospace and multiple spaces
collapse to one space.

Reproducible: Always
Steps to Reproduce:
1.open attached file
2.print preview
3.print

Actual Results:  Printed output was in variable pitch font and multiple spaces
collapsed to one space.

Expected Results:  Print using monospace font and preserve extra spaces.

I'm trying to deliver text reports to a browser and know that a subset of users
will want to print using the browser print function.  IE 5.5 and 6.0 print
functions behave as I expected, using a monospace font and preserving extra
spaces.  MOZILLA 1.0 RC1 does not.  I would like to keep MOZILLA/NETSCAPE in the
game.
(Reporter)

Comment 1

16 years ago
Created attachment 82187 [details]
simple test of preformatted text
This looks like a duplicate of bug 37685, except that's supposed to be fixed...

Also, I cannot reproduce this with Linux trunk build 2002-05-01-21.  The text
prints in a fixed-width font...  Windows-only?
Keywords: pp

Comment 3

15 years ago
The test printed properly for me on 1.3, Win2kPro.

Since this bug is pretty old, I'm gonna mark it as WFM.  If you're still seeing
this issue reporter, please feel free to re-open this bug.

If you do, please tell us what version of Windows you're running and what
printer you're using.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.