Middle-clicking on scrollbar also pastes previously selcted text

RESOLVED DUPLICATE of bug 70698

Status

RESOLVED DUPLICATE of bug 70698
17 years ago
14 years ago

People

(Reporter: mbmarduk, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020428
BuildID:    2002042807

Middle-clicking on a scrollbar of a forum's add-reply window also pastes
previously selcted text in one fell swoop.
There's a scrollbar when quoting someone else's text (when it's more than the
window shows ofcourse). When middle-clicking on the scrollbar to instantly go to
a certain position/line in the window, text previously highlined by the users
gets inserted at the current position.
This can't be a feauture -thank you very much- as it sucks 'cause your quoted
text becomes a sea of text to edit.


Reproducible: Always
Steps to Reproduce:
1.Highlight any text anywhere
2.Got to URL (which is a "reply-quoted" window on a forum)
3.Middle-click on the scrollbar (somwhere BELOW the scrollbar-button itself)


Actual Results:  4.Watch your previously highlighted text automagically be
added/pasted to the quoted text...yuck!

Expected Results:  Text shouldn't be added/pasted
Duplicate of "Pasting _ON_ TEXTAREA or Composer scrollbar controls draws text"

*** This bug has been marked as a duplicate of 70698 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.