Closed Bug 1420550 Opened 3 years ago Closed 3 years ago

Firefox Android will not run in Samsung DeX Docked mode

Categories

(Firefox for Android :: General, defect)

Firefox 56
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 845270

People

(Reporter: kenneth.fechter, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) SamsungBrowser/6.2 Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce:

With Galaxy Note8 Docked in the Samsung DeX Dock, I attempted to open Firefox 


Actual results:

Dex shows a toast messaging saying that Firefox will not work in DeX mode because it is set to require touch in the manifest


Expected results:

firefox should open as a windowed app with a resizeable window
I am willing to test things as I have a DeX. I am also willing to pull the firefox android source and submit a fix.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 845270
Workaround possible by enabling dev. mode in DEX:

https://forum.xda-developers.com/galaxy-note-8/help/firefox-dex-station-mode-t3673189

But best would be still Mozilla fixes it natively.
(In reply to Atanas from comment #3)
> Workaround possible by enabling dev. mode in DEX:
> 
> https://forum.xda-developers.com/galaxy-note-8/help/firefox-dex-station-mode-
> t3673189
> 
> But best would be still Mozilla fixes it natively.

This solution works on the Samsung Galaxy Note9 also. Note: you will need to restart DeX by disconnecting it from and then reconnecting it to the external monitor for the change to take hold.
You need to log in before you can comment on or make changes to this bug.