Reduce I/O caused by storing page metadata

RESOLVED FIXED in Firefox 59

Status

()

enhancement
P1
normal
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: mak, Assigned: mak)

Tracking

(Blocks 1 bug, {perf})

unspecified
mozilla59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

Assignee

Description

2 years ago
We seem to be storing the additional metadata at each visit, but like favicons this is data that doesn't change often (if at all), thus most of the times we are just overwriting the same identical data.

I'd like us to store new metadata only if it changed.
Assignee

Updated

2 years ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)

Comment 2

2 years ago
mozreview-review
Comment on attachment 8932141 [details]
Bug 1420571 - Don't write unchanged page metadata to places.sqlite.

https://reviewboard.mozilla.org/r/203172/#review209220

It's been a while, but I'm guessing .affectedRows isn't used due to intermittents because who knows what query might happen to jump in between an UPDATE and test check? https://searchfox.org/mozilla-central/search?q=affectedRows
Attachment #8932141 - Flags: review?(edilee) → review+
Assignee

Comment 3

2 years ago
We cannot trust affectedRows in connections that can be used on 2 threads, because the other thread could touch it before we read it. We can trust it only on single-threaded connections, thus potentially it could be usable in Sqlite.jsm IF the connection is not a wrapped one.

Comment 4

2 years ago
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/7c7c4ab0020a
Don't write unchanged page metadata to places.sqlite. r=Mardak
Assignee

Updated

2 years ago
Blocks: PlacesIO
Assignee

Updated

2 years ago
No longer blocks: 1419053

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7c7c4ab0020a
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.