Closed Bug 1421025 Opened 2 years ago Closed 2 years ago

'Support down-scaling per track in getUserMedia' breaks --disable-webrtc

Categories

(Firefox Build System :: General, defect, P5)

defect

Tracking

(firefox59 wontfix)

RESOLVED WONTFIX
Tracking Status
firefox59 --- wontfix

People

(Reporter: intermittent-bug-filer, Assigned: mchiang)

References

Details

(Whiteboard: [stockwell fixed:backout])

Attachments

(1 file)

Flags: needinfo?(tom)
From Bug 1388219

I believe that the problem is that this line: https://hg.mozilla.org/integration/autoland/rev/341aaeb4ce69#l4.12 is not present in all the compilation units that sId (https://hg.mozilla.org/integration/autoland/rev/341aaeb4ce69#l1.12) is declared in.  I don't know why this doesn't affect anyone other than MinGW though.
Ah, no that's partly true. The real problem is that MinGW turns on --disable-webrtc, and Bug 1388219 breaks that compilation target.
Flags: needinfo?(tom) → needinfo?(mchiang)
Summary: Permafailure gmake[4]: *** [xul.dll] Error 1 → 'Support down-scaling per track in getUserMedia' breaks --disable-webrtc
Assignee: nobody → mchiang
Flags: needinfo?(mchiang)
Blocks: 1388219
No longer depends on: 1388219
Comment on attachment 8932346 [details]
Bug 1421025 - fix build break with --disable-webrtc.

https://reviewboard.mozilla.org/r/203386/#review208812

This LGTM assuming it builds successfully. However I don't have enough permissions for autoland to land commits r+-ed by me, so unless you do, you will need to get another review.
Attachment #8932346 - Flags: review?(tom) → review+
Pushed by mchiang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1a69438ec05f
fix build break with --disable-webrtc. r=tjr
https://hg.mozilla.org/mozilla-central/rev/1a69438ec05f
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Duplicate of this bug: 1421147
Backed out alongside bug 1388219. Calling this wontfix under the assumption that you'll just fold this fix into bug 1388219 when it's ready to re-land.

https://hg.mozilla.org/mozilla-central/rev/91fc3a79606b
Resolution: FIXED → WONTFIX
Target Milestone: mozilla59 → ---
Whiteboard: [stockwell fixed:backout]
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.