Closed Bug 1421240 Opened 5 years ago Closed 3 years ago

WebRTC/TURN doesn't use system HTTP proxy

Categories

(Core :: WebRTC: Networking, defect, P3)

58 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1569183

People

(Reporter: jamie.woods, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171118220429

Steps to reproduce:

1. Set macOS system proxy to www-proxy:8080
2. Set Firefox to inherit system proxy 
3. Use Trickle ICE demo (https://webrtc.github.io/samples/src/content/peerconnection/trickle-ice/) with a TURN server (e.g. turn:myturn:3478?transport=tcp)


Actual results:

Firefox tries to connect directly to TURN server, instead of through the HTTP proxy that we've defined in system settings. 


Expected results:

Firefox should connect to the HTTP proxy to establish its TURN connection. Behaviour should be identical to manually setting HTTP proxy settings in Firefox's preferences.
Component: Untriaged → WebRTC: Networking
Product: Firefox → Core
Jamie do you know if it works if the proxy is configured directly in the Firefox proxy settings and not inherited from the OS?
Flags: needinfo?(jamie.woods)
Whiteboard: [need info reporter 2017-11-28]
Yes. The issue goes away when I use Firefox's "Manual proxy configuration" (and copy exactly the proxy settings from Preferences.app, but having them exact is not in itself a requirement for the bug), and returns when I re-select the "Use system proxy settings" option. (Apologies, I thought I'd implied this in my initial report!)
Flags: needinfo?(jamie.woods)
Turns out we need to implement additional logic to support proxy auto config.
Status: UNCONFIRMED → NEW
Rank: 25
Ever confirmed: true
Priority: -- → P3
Summary: WebRTC/TURN doesn't use system proxy → WebRTC/TURN doesn't use system HTTP proxy
Whiteboard: [need info reporter 2017-11-28]
Duplicate of this bug: 1471700
(In reply to Nils Ohlmeier [:drno] from comment #3)
> Turns out we need to implement additional logic to support proxy auto config.

Bug 1471700 says this is a regression and it used to work in 52esr.
I think Bug 1471700 is a different issue. When I switch to Firefox's "Manual proxy configuration" using the same proxy server, Firefox still does not use that proxy server for TURN.
Depends on: 1569183

This is probably fixed now that bug 1569183 has landed, but I need to verify.

Flags: needinfo?(docfaraday)

Yeah, this seems to be working now.

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(docfaraday)
Resolution: --- → DUPLICATE
Duplicate of bug: 1569183
You need to log in before you can comment on or make changes to this bug.