Closed Bug 1421621 Opened 2 years ago Closed 2 years ago

The text from "Clear Form" button is not translated to the build language

Categories

(Mozilla Localizations :: fr / French, defect)

defect
Not set

Tracking

(firefox59 affected)

RESOLVED INVALID
Tracking Status
firefox59 --- affected

People

(Reporter: Ovidiu, Assigned: bugzilla.fr)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [form autofill: V2])

Attachments

(1 file)

[Affected versions]:

Tested on Nightly 59.0a1(2017-11-28)

[Affected platforms]:

Tested on Mac OS X 10.13, Windows 10

[Steps to reproduce]:

Prerequisites:
 1. Make sure you have at least two saved profile.
 2. Install Firefox Nightly - French build - http://archive.mozilla.org/pub/firefox/nightly/2017/11/2017-11-26-22-03-11-mozilla-central-l10n/
 
1. Go to https://luke-chang.github.io/autofill-demo/basic.html
2. Double click on the "Name" field and select a profile, fill in.
3. Click again on the "Name" field.


[Expected result]:

A drop down with 2 buttons is shown, the text of the buttons is translated in the language of the build installed from Prerequisites. 
On Windows, you have "Clear Form" button and "Options" button. 
On Mac and Linux you have "Clear Form" button and "Préférences" button. 
"Clear Form" should be translated into the build language that you installed from Prerequisites. 

[Actual result]:

The text from "Clear Form" button is not translated into the build language that you installed from Prerequisites.
Whiteboard: [form autofill: V2]
Clear button just landed last week. It may need more time to be translated. Leave this bug open for tracking. Thanks for reporting.
Blocks: 1404768, fx-autofill-l10n
No longer blocks: fx-form-autofill
Assignee: nobody → bugzilla.fr
Component: Form Autofill → fr / French
Product: Toolkit → Mozilla Localizations
QA Contact: benoit.leseul
Version: Trunk → unspecified
We 're having issues with the system that exposes strings to tools (Pontoon). That means that all locales but Italian don't even have that string yet.

As a general advice: if you want to test a localization, please use Italian ;-)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
For reference, the string is correctly translated in the Italian build (which doesn't follow the normal localization process, and is up to speed with mozilla-central).
Hello Francesco,

Now the "Clear Form" button label is "Clear Autofill Form", this text is not translated, we need to track this issue. How do you suggest to do that, reopen this bug, fill in another bug or do you have a bug that handles this issue? Thanks
Flags: needinfo?(francesco.lodolo)
This new string has been exposed yesterday, and you should be able to verify it on an Italian build.

I'm not sure I can answer the specific question, since I don't understand what you mean with tracking the issue. 

As said in the past, languages will add their translations at different times, that's why this bug was closed as invalid.
Flags: needinfo?(francesco.lodolo)
You need to log in before you can comment on or make changes to this bug.