Closed Bug 1421819 Opened 4 years ago Closed 4 years ago

Only create webrtc::call() object on video calls

Categories

(Core :: WebRTC, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: drno, Assigned: drno)

References

Details

Attachments

(1 file, 1 obsolete file)

Every time a PeerConnection gets instantiated we create a webrtc::call() object, which itself starts two threads. But none of this is needed for PeerConnections which don't use any video.

Note: this will change once the Audio pieces switch over to use the Call object as well. But even then we should not spin up these threads for data channel only PeerConnections.
Comment on attachment 8933109 [details]
Bug 1421819: only init Call object when really needed.

https://reviewboard.mozilla.org/r/204084/#review209928
Attachment #8933109 - Flags: review?(docfaraday) → review+
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s afadf176e29c -d a3fd8af4122e: rebasing 436840:afadf176e29c "Bug 1421819: only init Call object when really needed. r=bwc" (tip)
other [source] changed media/webrtc/signaling/src/peerconnection/MediaPipelineFactory.cpp which local [dest] deleted
use (c)hanged version, leave (d)eleted, or leave (u)nresolved? u
merging media/webrtc/signaling/src/peerconnection/PeerConnectionMedia.cpp
warning: conflicts while merging media/webrtc/signaling/src/peerconnection/PeerConnectionMedia.cpp! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Attachment #8933109 - Attachment is obsolete: true
Comment on attachment 8933523 [details]
Bug 1421819: only init Call object in Tranceivers.

https://reviewboard.mozilla.org/r/204468/#review210596
Attachment #8933523 - Flags: review?(docfaraday) → review+
Pushed by drno@ohlmeier.org:
https://hg.mozilla.org/integration/autoland/rev/fad08f2edb7e
only init Call object in Tranceivers. r=bwc
Rank: 9
https://hg.mozilla.org/mozilla-central/rev/fad08f2edb7e
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Duplicate of this bug: 1375818
You need to log in before you can comment on or make changes to this bug.