Google Maps map with many pins is very slow to load pins

VERIFIED FIXED in Firefox 62

Status

()

P1
normal
VERIFIED FIXED
a year ago
6 months ago

People

(Reporter: yoasif, Assigned: mattwoodrow)

Tracking

Trunk
mozilla63
Points:
---

Firefox Tracking Flags

(firefox62+ verified, firefox63 verified)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171129220149

Steps to reproduce:

1. Navigate to: http://suffolkcamra.co.uk/pubs/cgi-bin/demomap.cgi


Actual results:

Firefox takes about 25 seconds to load all pins on map. 


Expected results:

Closer to Chrome's 5-6 seconds. 

Performance profile: https://perfht.ml/2BxDXbS
(Reporter)

Updated

a year ago
Component: General → Untriaged
Product: Core → Firefox
Component: Untriaged → Layout
Product: Firefox → Core
Priority: -- → P1
From the profile, it seems in the 36s range of content 1 process work, 30s is under PresShell::Paint, so it sounds like something slow is happening in painting.
Component: Layout → Layout: Web Painting
(Assignee)

Comment 2

9 months ago
Painting is pretty slow here, and there's lot to investigate there, but it seems like the main issue is that we're doing only a few markers each paint.

I had a look with Chrome and the paints are super slow there too (maybe worse even), but we only paint 2-3 times to add the entirety of the markers.

It seems like there's some sort of scheduling difference here that means we do way less work adding markers for each paint.

Smaug, do you know if there's anything intentional/known related to this? I haven't debugged it much yet, but it looked like it was using setTimout (TimeoutManager::RunTimeout in the profiler).

It's quite hard to figure out what the google maps API is doing (all minified source).
Flags: needinfo?(bugs)

Comment 5

9 months ago
mozreview-review
Comment on attachment 8990645 [details]
Bug 1421885 - Part 1: Don't let mNoActionRegion get complex when we've already added it to mDispatchToContentRegion.

https://reviewboard.mozilla.org/r/255722/#review262500
Attachment #8990645 - Flags: review?(bugmail) → review+

Comment 6

9 months ago
mozreview-review
Comment on attachment 8990646 [details]
Bug 1421885 - Part 2: Don't compute APZ touch-action regions on platforms that don't support touch gestures.

https://reviewboard.mozilla.org/r/255724/#review262502
Attachment #8990646 - Flags: review?(bugmail) → review+

Comment 7

9 months ago
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9f106d66d06e
Part 1: Don't let mNoActionRegion get complex when we've already added it to mDispatchToContentRegion. r=kats
https://hg.mozilla.org/integration/autoland/rev/42f32a0e7508
Part 2: Don't compute APZ touch-action regions on platforms that don't support touch gestures. r=kats
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 11

9 months ago
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cac0b0aa948e
Part 1: Don't let mNoActionRegion get complex when we've already added it to mDispatchToContentRegion. r=kats
https://hg.mozilla.org/integration/autoland/rev/faab566585a2
Part 2: Don't compute APZ touch-action regions on platforms that don't support touch gestures. r=kats

Comment 12

9 months ago
Backout by aciure@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/50526e5ade88
Backed out 2 changesets for test_group_touchevents-3.html failures CLOSED TREE
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 16

9 months ago
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b01200eb6ad4
Part 1: Don't let mNoActionRegion get complex when we've already added it to mDispatchToContentRegion. r=kats
https://hg.mozilla.org/integration/autoland/rev/0c55071115c2
Part 2: Don't compute APZ touch-action regions on platforms that don't support touch gestures. r=kats

Comment 17

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b01200eb6ad4
https://hg.mozilla.org/mozilla-central/rev/0c55071115c2
Status: NEW → RESOLVED
Last Resolved: 9 months ago
status-firefox63: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Assignee: nobody → matt.woodrow
Blocks: 1487890
(Assignee)

Comment 18

7 months ago
Comment on attachment 8990645 [details]
Bug 1421885 - Part 1: Don't let mNoActionRegion get complex when we've already added it to mDispatchToContentRegion.

Approval Request Comment
[Feature/Bug causing the regression]: Fixes bug 1487890
[User impact if declined]:
[Is this code covered by automated tests?]: Covered by the APZ test/
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Just adds some region simplification calls to improve performance, and fixes a bug in the process.
[String changes made/needed]: None.
Flags: needinfo?(matt.woodrow)
Attachment #8990645 - Flags: approval-mozilla-release?
Comment on attachment 8990646 [details]
Bug 1421885 - Part 2: Don't compute APZ touch-action regions on platforms that don't support touch gestures.

see comment 18.
Attachment #8990646 - Flags: approval-mozilla-release?
status-firefox62: --- → affected
tracking-firefox62: --- → +
I have managed to reproduce this issue using Firefox 59.0a1 (BuildId:20171129220149) on Windows 10 64bit.

This issue is verified fixed using Firefox 63.0b7 (BuildId:20180917143811) on Windows 10 64bit, macOS 10.13.6 and Ubuntu 16.04 64bit.
Status: RESOLVED → VERIFIED
status-firefox63: fixed → verified
Flags: qe-verify+
Comment on attachment 8990645 [details]
Bug 1421885 - Part 1: Don't let mNoActionRegion get complex when we've already added it to mDispatchToContentRegion.

fixing bug 1487890, approved for 62.0.2
Flags: needinfo?(bugs)
Attachment #8990645 - Flags: approval-mozilla-release? → approval-mozilla-release+
Attachment #8990646 - Flags: approval-mozilla-release? → approval-mozilla-release+
Duplicate of this bug: 1490625
Duplicate of this bug: 1491631
This issue is verified fixed using Firefox 62.0.2 (BuildId:20180920131237) on Windows 10 64bit, macOS 10.9.5 and Ubuntu 16.04 64bit.
status-firefox62: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.