[Error][mac] "Open in Preview" sometimes triggers a "Load the following paper into the rear tray" popup then fails

RESOLVED WONTFIX

Status

()

P2
normal
RESOLVED WONTFIX
a year ago
9 days ago

People

(Reporter: jwatt, Assigned: haik)

Tracking

({regression})

unspecified
Unspecified
Mac OS X
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 unaffected, firefox58 wontfix, firefox59 wontfix, firefox60 wontfix, firefox61 fix-optional)

Details

(Whiteboard: sb+)

(Reporter)

Description

a year ago
Loading:

data:text/html,hi

Then trying to print preview using File > Print... > PDF > Open in Preview, I sometimes get a popup with the message "Load the following paper into the rear tray" followed by Preview either crashing, or displaying a PDF with three blank pages.

Obviously there should be no message about loading paper when generating and displaying a PDF file.
(Reporter)

Comment 2

a year ago
This may end up being fixed or dup'ed to bug 1328975.
See Also: → bug 1328975
(Reporter)

Updated

a year ago
Keywords: regression
(Assignee)

Updated

a year ago
Assignee: nobody → haftandilian
Priority: -- → P1
Whiteboard: sb+
status-firefox57: --- → unaffected
status-firefox58: --- → affected
I can't seem to reproduce this in the newest Nightly, but not sure if that necessarily mean it's fixed.
status-firefox59: --- → ?
(Reporter)

Comment 4

a year ago
I can repro in 2017-12-06-10-00-53-mozilla-central.
(Reporter)

Updated

a year ago
Blocks: 1421309
(Assignee)

Comment 5

a year ago
Thanks, I'm looking into this. I haven't been able to reproduce it locally, but am going to start with the assumption it was introduced by bug 1403260.
(Assignee)

Comment 6

a year ago
@jwatt, are you running High Sierra 10.13.1 (17B1003)? If not, which OS version? Thanks.
Flags: needinfo?(jwatt)
(Reporter)

Comment 7

a year ago
I am, yes (or now 10.13.2).

But this seems to be something to do with a "zero" sized custom paper size that I set while debugging a different bug some time ago. Somehow that paper size is being picked as the default, and I didn't notice. So I'm not sure this is something we need to worry too much about. Having such a custom paper size is generally an indication of some bad state on a users machine.
Flags: needinfo?(jwatt)
(In reply to Jonathan Watt [:jwatt] (needinfo? me) from comment #7)
> But this seems to be something to do with a "zero" sized custom paper size
> ...
> paper size is generally an indication of some bad state on a users machine.

Does it only happen when the paper size is zero? It seems a corner case. That's said, a blank page is way better than crash.
(Assignee)

Comment 9

a year ago
Thanks. It's good to know that it's just happening with the zero sized page format. I attempted to create a zero custom paper size on 10.13.2, but the File->Print->Paper Size->Manage Custom Sizes... GUI wouldn't let me. I will still investigate this because it still seems like we have a bug in how we're handling the paper size or printer settings. We probably shouldn't be contacting the printer at all for a print to PDF.
Haik, do we think we can realistically get this fixed to be uplifted to 58? Thanks.
Flags: needinfo?(haftandilian)
(Assignee)

Comment 11

a year ago
(In reply to Mike Taylor [:miketaylr] (58 Regression Engineering Owner) from comment #10)
> Haik, do we think we can realistically get this fixed to be uplifted to 58?
> Thanks.

Yes. I don't know the root cause yet, but talked to :jwatt in person last week and got some more information that should help debugging. I am aiming to get this fixed in 58.
Flags: needinfo?(haftandilian)
status-firefox58: affected → fix-optional
status-firefox58: fix-optional → wontfix
status-firefox59: ? → affected
(Assignee)

Comment 12

a year ago
Reducing the priority because it turned out that on jwatt's laptop the printer driver had a setting for default page size and it was set to the 1x1 page size. I haven't been able to reproduce this with the driver alone (without the printer). jwatt, could you give me the exact printer model you have? I'll try to get one to test with.
Flags: needinfo?(jwatt)
Priority: P1 → P2
(Reporter)

Comment 13

a year ago
Canon MG6100 series _179998C7B513

I wouldn't worry too much about this though. For this to hurt people they:

 1) Need to be printing
 2) Need to have some misconfigured zero sized paper (which is hard to get)
 3) Possibly need my specific rather old printer

If you're add the point where you're considering going to the time and trouble of buying this printer, I'd say just move on to more important things. If we really care about this then I can try and make time to debug the issue myself.
Flags: needinfo?(jwatt)
Summary: [mac] "Open in Preview" sometimes triggers a "Load the following paper into the rear tray" popup then fails → [Error][mac] "Open in Preview" sometimes triggers a "Load the following paper into the rear tray" popup then fails
status-firefox59: affected → wontfix
status-firefox60: --- → wontfix
status-firefox61: --- → fix-optional
(Assignee)

Comment 14

9 days ago

I don't anticipate getting cycles to work on this so I'm closing the bug as WONTFIX. It can be reopened in the future if necessary.

Status: NEW → RESOLVED
Last Resolved: 9 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.