"Element could not be scrolled into view" if element is larger than viewport

RESOLVED DUPLICATE of bug 1374283

Status

defect
P2
normal
RESOLVED DUPLICATE of bug 1374283
2 years ago
5 months ago

People

(Reporter: barancev, Unassigned)

Tracking

(Blocks 1 bug)

59 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 affected)

Details

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36

Steps to reproduce:

With Java Selenium run this snippet:

driver.get("https://output.jsbin.com/lomigaf");
driver.findElement(By.id("click")).click();


Actual results:

ElementNotInteractableException: Element <a id="click" href="clicks.html"> could not be scrolled into view


Expected results:

The element sould be clicked.
Reporter

Comment 1

2 years ago
Trace level log:

1512126134300	geckodriver	INFO	geckodriver 0.19.1
1512126134310	geckodriver	INFO	Listening on 127.0.0.1:27535
1512126134976	mozrunner::runner	INFO	Running command: "C:\\Program Files\\Nightly\\firefox.exe" "-marionette" "-profile" "C:\\Users\\alexei\\AppData\\Local\\Temp\\rust_mozprofile.VujSu1X15bKG"
1512126136202	Marionette	DEBUG	Received observer notification "profile-after-change"
1512126136329	Marionette	DEBUG	Received observer notification "command-line-startup"
1512126136329	Marionette	INFO	Enabled via --marionette
1512126136516	geckodriver::marionette	TRACE	  connection attempt 0/600
1512126137616	geckodriver::marionette	TRACE	  connection attempt 1/600
1512126138129	Marionette	DEBUG	Received observer notification "sessionstore-windows-restored"
1512126138543	Marionette	DEBUG	Setting recommended pref toolkit.cosmeticAnimations.enabled to false
1512126138545	Marionette	DEBUG	Setting recommended pref datareporting.policy.dataSubmissionPolicyAccepted to false
1512126138545	Marionette	DEBUG	New connections are accepted
1512126138545	Marionette	INFO	Listening on port 56557
1512126138719	geckodriver::marionette	DEBUG	Connected to Marionette on localhost:56557
1512126138780	Marionette	DEBUG	Accepted connection 0 from 127.0.0.1:56564
1512126138781	geckodriver::marionette	TRACE	<- {"applicationType":"gecko","marionetteProtocol":3}
1512126138781	geckodriver::marionette	TRACE	-> 163:[0,1,"newSession",{"acceptInsecureCerts":true,"browserName":"firefox","capabilities":{"desiredCapabilities":{"acceptInsecureCerts":true,"browserName":"firefox"}}}]
1512126138783	Marionette	TRACE	0 -> [0,1,"newSession",{"acceptInsecureCerts":true,"browserName":"firefox","capabilities":{"desiredCapabilities":{"acceptInsecureCerts":true,"browserName":"firefox"}}}]
1512126138784	Marionette	WARN	TLS certificate errors will be ignored for this session
1512126138877	Marionette	DEBUG	Register listener.js for window 4294967297
1512126138980	webdriver::server	DEBUG	-> POST /session/448b1c86-08d9-43f6-94ce-864eb2a62023/timeouts {"implicit":10000}
1512126138980	geckodriver::marionette	TRACE	-> 38:[0,2,"setTimeouts",{"implicit":10000}]
1512126138982	Marionette	TRACE	0 -> [0,2,"setTimeouts",{"implicit":10000}]
1512126138984	Marionette	TRACE	0 <- [1,2,null,{}]
1512126138983	geckodriver::marionette	TRACE	<- [1,2,null,{}]
1512126138983	webdriver::server	DEBUG	<- 200 OK {"value": {}}
1512126138993	webdriver::server	DEBUG	-> POST /session/448b1c86-08d9-43f6-94ce-864eb2a62023/window/maximize {}
1512126138993	geckodriver::marionette	TRACE	-> 25:[0,3,"maximizeWindow",{}]
1512126138995	Marionette	TRACE	0 -> [0,3,"maximizeWindow",{}]
1512126139006	Marionette	TRACE	0 <- [1,3,null,{"x":-8,"y":-8,"width":1936,"height":1176,"state":"maximized"}]
1512126139042	geckodriver::marionette	TRACE	<- [1,3,null,{"x":-8,"y":-8,"width":1936,"height":1176,"state":"maximized"}]
1512126139042	webdriver::server	DEBUG	<- 200 OK {"value": {"height":1176,"width":1936,"x":-8,"y":-8}}
1512126139054	webdriver::server	DEBUG	-> POST /session/448b1c86-08d9-43f6-94ce-864eb2a62023/url {"url":"https://output.jsbin.com/lomigaf"}
1512126139054	geckodriver::marionette	TRACE	-> 54:[0,4,"get",{"url":"https://output.jsbin.com/lomigaf"}]
1512126139056	Marionette	TRACE	0 -> [0,4,"get",{"url":"https://output.jsbin.com/lomigaf"}]
1512126139071	Marionette	DEBUG	Received DOM event "beforeunload" for "about:blank"
1512126139735	Marionette	DEBUG	Received DOM event "pagehide" for "about:blank"
1512126140035	Marionette	DEBUG	Received DOM event "DOMContentLoaded" for "https://output.jsbin.com/lomigaf"
1512126140416	Marionette	DEBUG	Received DOM event "pageshow" for "https://output.jsbin.com/lomigaf"
1512126140417	Marionette	TRACE	0 <- [1,4,null,{}]
1512126140418	geckodriver::marionette	TRACE	<- [1,4,null,{}]
1512126140418	webdriver::server	DEBUG	<- 200 OK {"value": {}}
1512126140428	webdriver::server	DEBUG	-> POST /session/448b1c86-08d9-43f6-94ce-864eb2a62023/element {"value":"#click","using":"css selector"}
1512126140429	geckodriver::marionette	TRACE	-> 61:[0,5,"findElement",{"using":"css selector","value":"#click"}]
1512126140429	Marionette	TRACE	0 -> [0,5,"findElement",{"using":"css selector","value":"#click"}]
1512126140432	Marionette	TRACE	0 <- [1,5,null,{"value":{"uuid":"92f1f5b0-631b-4822-888a-9ca339c60b02"}}]
1512126140433	geckodriver::marionette	TRACE	<- [1,5,null,{"value":{"element-6066-11e4-a52e-4f735466cecf":"92f1f5b0-631b-4822-888a-9ca339c60b02","ELEMENT":"92f1f5b0-631b-4822-888a-9ca339c60b02"}}]
1512126140433	webdriver::server	DEBUG	<- 200 OK {"value":{"element-6066-11e4-a52e-4f735466cecf":"92f1f5b0-631b-4822-888a-9ca339c60b02"}}
1512126140442	webdriver::server	DEBUG	-> POST /session/448b1c86-08d9-43f6-94ce-864eb2a62023/element/92f1f5b0-631b-4822-888a-9ca339c60b02/click {"id":"92f1f5b0-631b-4822-888a-9ca339c60b02"}
1512126140443	geckodriver::marionette	TRACE	-> 66:[0,6,"clickElement",{"id":"92f1f5b0-631b-4822-888a-9ca339c60b02"}]
1512126140444	Marionette	TRACE	0 -> [0,6,"clickElement",{"id":"92f1f5b0-631b-4822-888a-9ca339c60b02"}]
1512126140454	Marionette	TRACE	0 <- [1,6,{"error":"element not interactable","message":"Element <a id=\"click\" href=\"clicks.html\"> could not be scrolled into view","stacktrace":"WebDriverError@chrome://marionette/content/error.js:172:5\nElementNotInteractableError@chrome://marionette/content/error.js:28 ... 13\nasync*navigate@chrome://marionette/content/listener.js:415:13\nclickElement@chrome://marionette/content/listener.js:1328:5\n"},null]
1512126140454	geckodriver::marionette	TRACE	<- [1,6,{"error":"element not interactable","message":"Element <a id=\"click\" href=\"clicks.html\"> could not be scrolled into view","stacktrace":"WebDriverError@chrome://marionette/content/error.js:172:5\nElementNotInteractableError@chrome://marionette/content/error.js:280:5\nwebdriverClickElement@chrome://marionette/content/interaction.js:160:11\nasync*interaction.clickElement@chrome://marionette/content/interaction.js:131:11\nasync*clickElement/<@chrome://marionette/content/listener.js:1329:14\nnavigate/<@chrome://marionette/content/listener.js:416:13\nasync*navigate@chrome://marionette/content/listener.js:415:13\nclickElement@chrome://marionette/content/listener.js:1328:5\n"},null]
1512126140454	webdriver::server	DEBUG	<- 400 Bad Request {"value":{"error":"element not interactable","message":"Element <a id=\"click\" href=\"clicks.html\"> could not be scrolled into view","stacktrace":"WebDriverError@chrome://marionette/content/error.js:172:5\nElementNotInteractableError@chrome://marionette/content/error.js:280:5\nwebdriverClickElement@chrome://marionette/content/interaction.js:160:11\nasync*interaction.clickElement@chrome://marionette/content/interaction.js:131:11\nasync*clickElement/<@chrome://marionette/content/listener.js:1329:14\nnavigate/<@chrome://marionette/content/listener.js:416:13\nasync*navigate@chrome://marionette/content/listener.js:415:13\nclickElement@chrome://marionette/content/listener.js:1328:5\n"}}
1512126140474	webdriver::server	DEBUG	-> DELETE /session/448b1c86-08d9-43f6-94ce-864eb2a62023 
1512126140474	geckodriver::marionette	TRACE	-> 37:[0,7,"quit",{"flags":["eForceQuit"]}]
1512126140475	Marionette	TRACE	0 -> [0,7,"quit",{"flags":["eForceQuit"]}]
1512126140476	Marionette	DEBUG	New connections will no longer be accepted
1512126140527	Marionette	TRACE	0 <- [1,7,null,{"cause":"shutdown"}]
1512126140545	geckodriver::marionette	TRACE	<- [1,7,null,{"cause":"shutdown"}]
1512126140545	webdriver::server	DEBUG	Deleting session
1512126140545	geckodriver::marionette	DEBUG	Stopping browser process
1512126141510	webdriver::server	DEBUG	<- 200 OK {"value": {}}
Maja, I think that this regression is related to the recently landed patch on bug 1393831. Can you please have a look?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(mjzffr)
Reporter

Comment 3

2 years ago
I'd not say it's a regression. We just did not try to run this test before the mentioned patch has been landed. But it was expected that the patch fixes this case. Unfortunately, it does not.
Oh, you are right. It was already not working before.
Thanks for the report.

https://github.com/mozilla/geckodriver/issues/901 reported an issue with the performActionz command, and that was fixed in Bug 1393831.

However, the trace log in in Comment 1 refers to the clickElement command, not performActions, so it has nothing to do with Bug 1393831.
Flags: needinfo?(mjzffr)
[Mass Change 2018-01-15] Moving bugs to backlog
Priority: -- → P3
Blocks: webdriver
Priority: P3 → P2

Comment 7

5 months ago
Any Update on this issue. As it still persists in Webdriver and I'm using it for protractor and getting this issue in firefox 64.
The child `div` actually fully overlays the anchor element, and as such this is a dupe of bug 1374283.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1374283
You need to log in before you can comment on or make changes to this bug.