xml-generated page does not display   properly

RESOLVED DUPLICATE of bug 98168

Status

()

RESOLVED DUPLICATE of bug 98168
17 years ago
17 years ago

People

(Reporter: frederic.gobry, Assigned: peterv)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
When I use mozilla to display a xml document whose html translation (with a
xslt stylesheet) contains   entities, these entities seem to be quoted,
(they appear as-is on the screen) whereas if I open the same file converted by
xsltproc, the rendering is ok.

I cannot provide you the exact document (bank account... :-{) but if you need,
I can try to extract a subset that causes the problem.
->XSLT
Assignee: heikki → peterv
Component: XML → XSLT
QA Contact: petersen → keith
(Reporter)

Comment 2

17 years ago
Created attachment 82331 [details]
xml, xslt and dtd files

Ok, finally I just cutted down the original file, and enclosed the version
generated by xsltproc (compte.html in the archive)
for the record, the attachment is an .tar.gz (took a few guesses to find the 
right one).

We don't, and can't, support disable-output-escaping in mozilla since we don't 
do any outputting (outputting in this context is serialzing the result).

Instead of

<xsl:text disable-output-escaping="yes">&nbsp;</xsl:text>

do

&#160;

doesn't that look way nicer! It works in all browsers and transformers too!

*** This bug has been marked as a duplicate of 98168 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Attachment #82331 - Attachment mime type: application/octet-stream → application/x-gzip
You need to log in before you can comment on or make changes to this bug.