Closed Bug 1422394 Opened 2 years ago Closed 2 years ago

Add a mechanism to safely report DLL load events

Categories

(Core :: mozglue, enhancement)

Unspecified
Windows
enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: aklotz, Assigned: aklotz)

References

Details

(Whiteboard: aes+)

Attachments

(1 file, 1 obsolete file)

We need this for UIA client detection because we cannot initiate that detection until *after* uiautomationcore.dll has been injected into our address space.
Note that this code is a bit more generic than it needs to be because I anticipate that we'll be enhancing this with additional functionality for InjectEject work.
Attachment #8934360 - Flags: review?(jmathies)
Attachment #8934360 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/8f233446cd06b7c91f66327cb8c8b0866eb68919
Bug 1422394: Follow-up: Add missing include to fix mingw bustage; r=bustage
Naturally I cannot reproduce this locally....
Flags: needinfo?(aklotz)
I was able to reproduce this on an opt build. This updated patch adds the various build fixes.
Attachment #8934360 - Attachment is obsolete: true
Attachment #8935089 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/d9ec1dda6c57
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.