Closed Bug 1422405 Opened 2 years ago Closed 2 years ago

geckoview_example is not respecting shutdown intent

Categories

(GeckoView :: General, defect)

defect
Not set

Tracking

(firefox59 fixed)

VERIFIED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: bc, Assigned: esawin)

References

Details

Attachments

(2 files, 1 obsolete file)

Attached file steps to reproduce
Autophone is having problems shutting down geckoview_example cleanly using the shutdown intent. This causes the geckoview_example tests to run much longer and possibly introduces noise since I have to wait 10 seconds before I force-stop it.

I thought we had this working after bug 1368701 but checking a geckoview_example from 2017-07-08 doesn't appear to work when attempting similar std.
Eugen please take a look.
Assignee: nobody → esawin
Flags: needinfo?(esawin)
Looks like I've never landed patch 2 from bug 1368701, sorry about that.
Flags: needinfo?(esawin)
Attachment #8934685 - Flags: review?(nchen)
Comment on attachment 8934685 [details] [diff] [review]
0001-Bug-1422405-1.0-Add-shutdown-intent-for-geckoview_ex.patch

Review of attachment 8934685 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/geckoview_example/src/main/java/org/mozilla/geckoview_example/GeckoViewActivity.java
@@ +114,5 @@
> +
> +        if (ACTION_SHUTDOWN.equals(intent.getAction())) {
> +            mKillProcessOnDestroy = true;
> +            GeckoThread.forceQuit();
> +            mGeckoView.onDetachedFromWindow();

We should let Android call `onDetachedFromWindow` instead of calling it ourselves.
Attachment #8934685 - Flags: review?(nchen) → review+
Addressed comments.
Attachment #8934685 - Attachment is obsolete: true
Attachment #8935047 - Flags: review+
Pushed by esawin@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a466956afa4e
[1.1] Add shutdown intent for geckoview_example. r=jchen
https://hg.mozilla.org/mozilla-central/rev/a466956afa4e
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Confirmed. This cut the run time for s1s2geckoview from 10 to 5 minutes. Thanks!
Status: RESOLVED → VERIFIED
See Also: → 1452399
Product: Firefox for Android → GeckoView
Target Milestone: Firefox 59 → mozilla59
You need to log in before you can comment on or make changes to this bug.