this.node has no properties

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: brant, Assigned: samir_bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ready to checkin], URL)

Attachments

(1 attachment, 1 obsolete attachment)

919 bytes, patch
law
: review+
jag-mozilla
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0+)
Gecko/20020503
BuildID:    2002050308

When preferences are opened, this.node has no properties appears in the
JavaScript Console.

Reproducible: Always
Steps to Reproduce:
1. Open JavaScript Console.
2. Clear JavaScript Console.
3. Click Edit > Preferences.

Actual Results:  The following appears in JavaScript Console:

Error: this.node has no properties
Source File: chrome://communicator/content/sidebar/sidebarOverlay.js
Line: 90

Expected Results:  No error appears in JavaScript Console.

The following also appears, but will be filed as a separate bug:

Error: contextPopup has no properties
Source File: chrome://cookie/content/cookieContextOverlay.xul
Line: 123
To sidebar.
Assignee: ben → sgehani
Status: UNCONFIRMED → NEW
Component: Preferences → Sidebar
Ever confirmed: true
OS: Windows XP → All
QA Contact: sairuh → sujay
Hardware: PC → All
(Assignee)

Comment 2

17 years ago
Created attachment 82527 [details] [diff] [review]
Patch v1.0.

Remove leftover crud from backed-out sidebar button on personal toolbar.
(Assignee)

Comment 3

17 years ago
law, please r.
jag, please sr.
(Assignee)

Comment 4

17 years ago
*** Bug 142266 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

17 years ago
Created attachment 82563 [details] [diff] [review]
Patch v2.0.

Without the irrelevant pref-applications.xul changes.
Attachment #82527 - Attachment is obsolete: true

Comment 6

17 years ago
Comment on attachment 82563 [details] [diff] [review]
Patch v2.0.

sr=jag
Attachment #82563 - Flags: superreview+

Comment 7

17 years ago
Comment on attachment 82563 [details] [diff] [review]
Patch v2.0.

r=law
Attachment #82563 - Flags: review+
(Assignee)

Updated

17 years ago
Whiteboard: [ready to checkin]
(Assignee)

Comment 8

17 years ago
Checked in (part of backout of sidebar personal toolbar button).
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 9

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.