Closed Bug 1422960 Opened 5 years ago Closed 5 years ago

Select menus won't open in devtools panels on Windows 10

Categories

(WebExtensions :: Developer Tools, defect)

57 Branch
Unspecified
Windows 10
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1417043

People

(Reporter: marcy.sutton, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36

Steps to reproduce:

Include a default HTML select element in a devtools panel and it won't open, even with the mouse on Windows 10.

Reproducible in this demo (also attached): https://github.com/marcysutton/webextensions-examples/tree/win10-devtools-bug

Install it in Firefox and try to open the select box.


Actual results:

The select won't open. Nothing happens.


Expected results:

The select should open and be usable inside of devtools panels.
Confirmed on Windows 10. Select boxes just don't react to clicks at all. Works fine on macOS.
Status: UNCONFIRMED → NEW
Component: Untriaged → WebExtensions: Developer Tools
Ever confirmed: true
OS: Unspecified → Windows 10
Product: Firefox → Toolkit
Duplicate of this bug: 1414371
This issue is definitely related to the oop extension mode (which is currently enabled by default only on Windows),
and we have fixed similar issues for other extension pages (e.g. the extension sidebar panel and the extension options ui pages).

I'm marking this as a duplicate of Bug 1417043 (which is already a blocker for Bug 1190679).
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1417043
Which bug should we follow for progress on this issue? It's not exactly clear based on the "Resolved duplicate" labels.

When do you expect a fix for this? Thanks so much.
Follow bug 1417043 for updates. It's currently an unassigned P3 which means its in the backlog waiting for a contributor to pick it up and take it on.
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.