Closed Bug 1422962 Opened 2 years ago Closed 2 years ago

The about:home favicon still flickers occasionally

Categories

(Firefox :: General, defect)

Unspecified
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1403648
Tracking Status
firefox59 --- affected

People

(Reporter: mehmet.sahin, Unassigned)

References

Details

Attachments

(2 files)

59.0a1 (2017-12-04) (64-Bit)
macOS 10.12.6

STR:

1.) Start Nightly
2.) Close all tabs via CMD-W
3.) Now press CMD-T to open a NewTab (=in this case a new window)

Actual: The default favicon appears with delay and pushes the title to the right.

Expected: The default favicon should appear immediately since bug 1401955 is already fixed.

A screencast is attached.
Blocks: 1401955
+screencast
Blocks: 1421456
No longer blocks: 1401955
Component: New Tab Page → General
Depends on: 1422074
OS: Mac OS X → All
Summary: [macOS] [NewTabPage] Show always Default Favicon doesn't work, if you open the first window with CMD-T → The about:home favicon still flickers occasionally
If I remove the link rel=icon in bug 1422074, the icon actually never appears on a new window.
(In reply to Ed Lee :Mardak from comment #2)
> If I remove the link rel=icon in bug 1422074, the icon actually never
> appears on a new window.

We might have to change the code to not even accept a different favicon for about:home or about:newtab. I could have thought of that earlier, I guess.. :)
Attached video flicker_repro_steps.mov
I have a detailed repro step for the flicker on macOS:

1.) Run Nightly without an open window
2.) Click on the Dock icon to open a new window

-> Result: first flicker is to see

3.) Visit a page in this tab
4.) Open a New Tab in this window with CMD-T

-> Result: Again a flicker in the second tab is to see

It seems that in both flicker cases the whole favicon dis-/reappears.

A screencast is attached.

Thanks for looking into this issue.
Bug 1422903 should have removed much of the remaining flicker but it's not completely defeated yet. The remaining flicker will probably get resolved by bug 1403648 (we have the same problem where the icon needs to be set asynchronously because the url to load resolves in a promise).
Depends on: 1403648, 1422903
Since a fix for this is already in flight in bug 1403648, I'm going to resolve this as a dupe of that bug. 

If the issue persists, please open a new bug, and reference these.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1403648
You need to log in before you can comment on or make changes to this bug.