Closed Bug 1423201 Opened 3 years ago Closed 2 years ago

convert uses of "defer" to "new Promise" - server/tests/mochitest directory

Categories

(DevTools :: General, enhancement, P4)

enhancement

Tracking

(firefox64 fixed)

RESOLVED FIXED
Firefox 64
Tracking Status
firefox64 --- fixed

People

(Reporter: shr7, Assigned: sreeise)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

No description provided.
Blocks: 1283869
Assignee: nobody → shreya.chandra96
Severity: normal → minor
Priority: -- → P4
Product: Firefox → DevTools
(In reply to shreya [:shr7] from comment #1)
> Created attachment 8934856 [details] [diff] [review]
> convert uses of defer to new Promise - server/tests/mochitest directory

shreya, so sorry we missed your patch !
If you have the time, and are willing to move it forward, could you try to rebase it against an up-to-date mozilla-central repository ?
If you don't have the time/don't want to do it, do you mind if someone else takes over ?

Thanks a lot and sorry again !
Flags: needinfo?(shreya.chandra96)
Hey Nicolas, I can work on this if shreya can't get to it.
Flags: needinfo?(nchevobbe)
Sure, let's do that for now since shreya did not answered yet.
If in the meantime they do answer, please understand that I will give them their patch the priority :)
Assignee: shreya.chandra96 → reeisesean
Flags: needinfo?(nchevobbe)
(In reply to Nicolas Chevobbe [:nchevobbe] from comment #4)
> Sure, let's do that for now since shreya did not answered yet.
> If in the meantime they do answer, please understand that I will give them
> their patch the priority :)

For sure, no worries. Thanks.
Functions using 'defer' for promises are being switched to the 'new Promise' syntax. This is for changes in devtools/server/tests/mochitest.
The patch includes fixes for linting errors shown in try build as well.
Comment on attachment 9011387 [details]
Bug 1423201 - Changed uses of defer to new Promise in devtools/server/tests/mochitest r?nchevobbe

Nicolas Chevobbe [:nchevobbe] has approved the revision.
Attachment #9011387 - Flags: review+
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: checkin-needed
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/816d356e8fc7
Changed uses of defer to new Promise in devtools/server/tests/mochitest r=nchevobbe
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/816d356e8fc7
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
clearing flag
Flags: needinfo?(shreya.chandra96)
You need to log in before you can comment on or make changes to this bug.