Closed Bug 1423518 Opened 2 years ago Closed 2 years ago

Video corruption with Samsung Galaxy S4 Mini GT-I9195

Categories

(Firefox for Android :: Audio/Video, defect)

Firefox 59
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- wontfix
firefox58 --- fixed
firefox59 --- fixed

People

(Reporter: 12th23, Assigned: JamesCheng, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image ff_yt.png
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171128222554

Steps to reproduce:

Device: Samsung s4 mini GT-I9195 (Android 4.4.2)
Firefox beta, firefox, newest version (Dec 2017)
installed, uninstalled, installed.




Actual results:

Videos don't work (e.g. youtube or ZDF-mediathek). It always looks like the picture enclosed (in motion). Opera or the system browser work fine. 




Expected results:

video should work
Could you help please? THX
It seems like the same symptom as sub Bug of Bug 1362271.

I will add this device into blacklist.

Thanks for reporting this issue.
Assignee: nobody → jacheng
Attachment #8934921 - Flags: review?(jolin)
Comment on attachment 8934921 [details]
Bug 1423518 - Add Samsung Galaxy S4 Mini GT-I9195 into blacklist.

https://reviewboard.mozilla.org/r/205850/#review211382

Thanks!
Attachment #8934921 - Flags: review?(jolin) → review+
Summary: Videos do not work → Video corruption with Samsung Galaxy S4 Mini GT-I9195
Hi poiuzz,

Thanks for reporting this issue and I have landed the patch.

Ideally, it will be merged into Nightly soon(Maybe the day after tomorrow).

Could you please test the Nightly (the day after tomorrow) to see if it solves your problem?

If it is fixed, I will request uplifting to Beta and Release version.

Thanks.
Flags: needinfo?(12th23)
Pushed by jacheng@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0966f2eb06c5
Add Samsung Galaxy S4 Mini GT-I9195 into blacklist. r=jolin
Thanks for the fast response. I'll test the nightly next days.
Flags: needinfo?(12th23)
https://hg.mozilla.org/mozilla-central/rev/0966f2eb06c5
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Hi poiuzz,

The fix has been landed,

Please try 12/08 or 12/09 Nightly to see if it is fixed.

You can enter "about:support" and see "Build ID", it should >= 12/07.

Thank you.
Hi All,
Problem is fixed :-).
Thanks, and I will request uplift the bug to Beta

Thank you for helping us!
Comment on attachment 8934921 [details]
Bug 1423518 - Add Samsung Galaxy S4 Mini GT-I9195 into blacklist.

Approval Request Comment
[Feature/Bug causing the regression]:Bug 1317239
[User impact if declined]:Video corruption on Galaxy S4 Mini GT-I9195
[Is this code covered by automated tests?]:No
[Has the fix been verified in Nightly?]:No
[Needs manual test from QE? If yes, steps to reproduce]: Would be helpful. Simply play a video on an affected Galaxy S4 Mini GT-I9195
[List of other uplifts needed for the feature/fix]:None
[Is the change risky?]:No
[Why is the change risky/not risky?]:It only disables a feature that was only recently added on a certain device.
[String changes made/needed]: None
Attachment #8934921 - Flags: approval-mozilla-beta?
Blocks: 1362271
Comment on attachment 8934921 [details]
Bug 1423518 - Add Samsung Galaxy S4 Mini GT-I9195 into blacklist.

fix video issue on a samsung phone, beta58+
Attachment #8934921 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Hi Poiuzz,

Since this is a device specific issue and we don't have access to a S4 Mini, could you please try to verify this on the latest beta build(preferably on 58.0b11) to be sure that it works fine?

Thanks in advance.
Flags: needinfo?(12th23)
You need to log in before you can comment on or make changes to this bug.