Closed Bug 1423566 Opened 2 years ago Closed 2 years ago

Firefox assist app: if Firefox is in tab view, switch to the newly opened tab

Categories

(Firefox for Android :: General, defect, P3)

Firefox 59
All
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 59
Tracking Status
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- fixed

People

(Reporter: mark.paxman99, Assigned: JanH)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_1) AppleWebKit/604.3.5 (KHTML, like Gecko) Version/11.0.1 Safari/604.3.5

Steps to reproduce:

Follow on from bug 1413739
Long pressing the home button results in Firefox being called (Assist app) with a new tab.

But...

If Firefox was previously left with the tabs tray open, invoking the assist button just shows the tabs tray.
Firefox should switch to the newly opened tab, even if the tab tray was opened.

See also bug 1350994
Hi Jan
Please help advise. Thanks!
Flags: needinfo?(jh+bugzilla)
Priority: -- → P3
Hmm, in theory it's just another variety of bug 1350994, although the fact that we open edit mode causes some additional weirdness, because no matter what tab you select from the tabs tray, you end up in edit mode and when you then leave edit mode, in the newly opened assist intent tab. I'll try and see if there's some easy way of doing this without waiting for the rest of bug 1350994.
Assignee: nobody → jh+bugzilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jh+bugzilla)
OS: Unspecified → Android
Hardware: Unspecified → All
Version: 57 Branch → Firefox 59
Comment on attachment 8940285 [details]
Bug 1423566 - Hide tabs tray when receiving an Assist App intent.

https://reviewboard.mozilla.org/r/210556/#review216546
Attachment #8940285 - Flags: review?(cnevinchen) → review+
Pushed by mozilla@buttercookie.de:
https://hg.mozilla.org/integration/autoland/rev/2837beb13320
Hide tabs tray when receiving an Assist App intent. r=nechen
https://hg.mozilla.org/mozilla-central/rev/2837beb13320
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Fixed for me too.

Thanks for adding this Assist feature so quickly. Now I have one-touch access to the Awesomescreen which is Awesome.

Now, for an encore, how about pull-to-reload? I know it's been subject of a Big Mozilla Debate for years ;)
You need to log in before you can comment on or make changes to this bug.