Closed Bug 1423590 Opened 2 years ago Closed 2 years ago

[Stylo-chrome] "More Tools..." button on Nighlty 59 doesn't look the same as on Firefox 57

Categories

(Core :: CSS Parsing and Computation, defect)

x86_64
Windows
defect
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
firefox57 --- unaffected
firefox58 --- affected
firefox59 --- affected

People

(Reporter: miriapodzemos.my, Unassigned)

References

Details

Attachments

(1 file)

Attached image More tools button.jpg
[Affected versions]: 
Nightly 59.0a1

[Affected platforms]:
Platforms: Windows 7 & 10 x 64 and 32

[Preconditions]:
1. Go to about:config
2. "layout.css.servo.enabled" pref's default value is already TRUE
3. Set “layout.css.servo.chrome.enabled” to TRUE
4. Restart Firefox for the "layout.css.servo.chrome.enabled" pref change to take effect

[Steps to reproduce]:
1. Launch Firefox.
2. From toolbar click on "Hamburger menu".
3. Click on "Customize...".
4. Compare the results 

[Expected result]:
"More Tools..." button color should match with Stylo-chrome with Firefox 57's UI.

[Actual result]:
"More Tools..." button color doesn't match comparing with Stylo-chrome with Firefox 57's UI.
So, this seems to be something which isn't changed by whether stylo-chrome is enabled, so it's probably just a frontend change, rather than a stylo-chrome regression.

I think cpeterson's note mentioning to compare Firefox 59 with stylo-chrome to Firefox 57 is not correct. We should probably compare Firefox 59 with stylo-chrome to Firefox 59 without stylo-chrome.

Given these, I think we should close this, as well as some other bugs as INVALID.
Deac, my suggestion to compare Firefox 59 with stylo-chrome to Firefox 57 was a bad idea. I didn't realize how many front-end UI changes, like this "More Tools" button, were made since Firefox 57. Sorry!

Ovidiu pinged me on Slack and we concluded that we should not use Firefox 57 for comparison. We should just compare Firefox 59 with the "layout.css.servo.chrome.enabled" = true and = false. You will need to restart the browser after changing the pref value.
Resolving as invalid because this UI difference is a design change in Firefox 58 unrelated to stylo-chrome.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.