New tab favicon flickers twice if browser.newtab.preload=false

RESOLVED FIXED in Firefox 59

Status

()

Firefox
New Tab Page
RESOLVED FIXED
2 months ago
17 days ago

People

(Reporter: Felipe, Assigned: johannh)

Tracking

({regression})

58 Branch
Firefox 59
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox57 unaffected, firefox58 unaffected, firefox59 fixed)

Details

(Whiteboard: [fixed by bug 1422903])

Attachments

(1 attachment)

(Reporter)

Description

2 months ago
Created attachment 8935097 [details]
newtab-double-flicker.mov

The favicon for the new tab page flickers twice (shows up, goes away, then shows up again, I believe) when opening a new tab. This only happens with browser.newtab.preload = false.

This started on recent nightlies. I haven't had a chance to verify with mozregression yet, but due to the timing and issue, I imagine it is a regression from bug 401955

I'm attaching a screen recording of the issue
(Reporter)

Comment 1

2 months ago
(In reply to :Felipe Gomes (needinfo me!) from comment #0)
bug 401955

I mean bug 1401955
Blocks: 1401955
No longer blocks: 401955
(Assignee)

Comment 2

a month ago
I might fix this in bug 1422903...
Depends on: 1422903
(Assignee)

Comment 3

20 days ago
I can't reproduce anymore, so I'll assume it's fixed.
Status: NEW → RESOLVED
Last Resolved: 20 days ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 1422903]
Assignee: nobody → jhofmann
status-firefox57: --- → unaffected
status-firefox58: --- → unaffected
status-firefox59: --- → fixed
status-firefox-esr52: --- → unaffected
Target Milestone: --- → Firefox 59
You need to log in before you can comment on or make changes to this bug.