Closed Bug 1424175 Opened 2 years ago Closed 2 years ago

Copy a Chinese url from the url bar give a non-readable string

Categories

(Firefox :: Address Bar, defect)

58 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1320061

People

(Reporter: guillaume-heritiana.sabatie, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171204150510

Steps to reproduce:

Copy and paste url from a japanese website.



Actual results:

give this url http://www.dell.com/zh-cn/shop/alienware-%E5%BC%82%E6%98%9F%E8%80%8517%E8%8B%B1%E5%AF%B8%E8%83%8C%E5%8C%85/apd/460-bchv/%E6%B8%B8%E6%88%8F


Expected results:

should be this url  http://www.dell.com/zh-cn/shop/alienware-异星者17英寸背包/apd/460-bchv/游戏
Component: Untriaged → Serializers
Product: Firefox → Core
FYI: This is not Japanese. It is Chinese(zh-cn).
A workaround here is to flip "browser.urlbar.decodeURLsOnCopy" to true in "about:config" page with your own risk management.
You could get more contexts in bug 1320061.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Component: Serializers → Address Bar
Product: Core → Firefox
Resolution: --- → DUPLICATE
Summary: Copy an japanese url from the url bar give a wrong url → Copy a Chinese url from the url bar give a non-readable string
Duplicate of bug: 1320061
You need to log in before you can comment on or make changes to this bug.