Closed Bug 1424324 Opened 2 years ago Closed 2 years ago

2.14 - 4.26% Explicit Memory / JS (linux32-stylo-disabled, linux64, linux64-stylo-disabled, linux64-stylo-sequential, osx-10-10, windows10-64, windows7-32) regression on push 1938afc341937d701acfb196279193f4cc640696 (Thu Dec 7 2017)

Categories

(Core :: JavaScript: GC, defect, P1)

53 Branch
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox59 --- affected

People

(Reporter: jmaher, Unassigned)

References

Details

(Keywords: perf, regression, Whiteboard: [MemShrink])

We have detected an awsy regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=1938afc341937d701acfb196279193f4cc640696

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  4%  JS windows7-32 opt      86,739,131.78 -> 90,431,637.26
  4%  JS windows7-32 pgo      86,701,399.20 -> 90,134,308.28
  4%  JS windows10-64 opt     116,317,375.92 -> 120,719,793.82
  4%  JS windows10-64 pgo     116,374,661.39 -> 120,585,978.24
  4%  JS linux64-stylo-disabled opt stylo-disabled104,865,317.16 -> 108,633,761.60
  4%  JS linux64-stylo-sequential opt stylo-sequential105,107,892.74 -> 108,844,958.23
  3%  JS linux64 opt          105,140,497.73 -> 108,580,428.47
  3%  JS osx-10-10 opt        104,374,958.75 -> 107,454,751.23
  3%  Explicit Memory windows7-32 opt 260,442,013.65 -> 267,648,954.29
  3%  JS linux32-stylo-disabled opt stylo-disabled76,284,811.06 -> 78,198,688.36
  2%  Explicit Memory windows10-64 opt 324,469,318.92 -> 332,484,375.66
  2%  Explicit Memory windows10-64 pgo 323,483,797.88 -> 331,389,311.27
  2%  Explicit Memory windows7-32 pgo 260,357,980.12 -> 266,494,005.47
  2%  Explicit Memory linux64-stylo-sequential opt stylo-sequential321,479,292.35 -> 328,744,143.93
  2%  Explicit Memory linux64 opt 323,548,220.29 -> 330,801,370.57
  2%  Explicit Memory linux64-stylo-disabled opt stylo-disabled316,438,811.85 -> 323,198,402.48


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=10942

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/AWSY/Tests
:jonco, I see you authored the patches in bug 1422575, can you look at this regression?
Flags: needinfo?(jcoppeard)
Component: Untriaged → JavaScript: GC
Product: Firefox → Core
The same patch seems to have regressed some tests from Six Speed on AWFY.
Whiteboard: [MemShrink]
(In reply to Guilherme Lima from comment #2)
I can see a ~20% regression in six-speed-classes-es5 at least.

Due to the memory increase and this I'll back out the patches in bug 1422575.
Flags: needinfo?(jcoppeard)
Duplicate of this bug: 1424779
Priority: -- → P1
Backout landed, closing.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Memory use seems to have returned to previous levels.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → WORKSFORME
(In reply to Jon Coppeard (:jonco) from comment #6)
> Memory use seems to have returned to previous levels.

Confirming that with data:

== Change summary for alert #10996 (as of Tue, 12 Dec 2017 20:51:41 GMT) ==

Improvements:

  4%  JS windows7-32 opt      90,322,634.46 -> 86,743,107.71
  4%  JS windows7-32 pgo      90,253,201.09 -> 86,956,080.23
  4%  JS windows10-64 opt     120,449,604.33 -> 116,086,224.06
  3%  JS windows10-64 pgo     120,430,060.12 -> 116,228,861.05
  3%  JS linux64-stylo-sequential opt stylo-sequential108,762,553.91 -> 105,020,477.66
  3%  JS linux64-stylo-disabled opt stylo-disabled108,416,530.18 -> 105,269,347.80
  3%  Explicit Memory windows7-32 opt 266,995,862.81 -> 259,327,083.78
  3%  JS linux64 opt          108,375,639.86 -> 105,319,760.88
  3%  JS osx-10-10 opt        107,270,220.60 -> 104,266,487.33
  3%  Explicit Memory windows10-64 opt 332,374,986.91 -> 323,394,620.22
  3%  Explicit Memory windows7-32 pgo 267,796,784.93 -> 260,795,554.40
  2%  Explicit Memory linux64-stylo-sequential opt stylo-sequential328,668,932.72 -> 320,844,139.53
  2%  JS linux32-stylo-disabled opt stylo-disabled77,908,059.67 -> 76,120,996.36
  2%  Explicit Memory linux64-stylo-disabled opt stylo-disabled323,207,361.97 -> 316,029,147.66
  2%  Explicit Memory windows10-64 pgo 330,789,755.82 -> 323,432,851.23
  2%  Heap Unclassified windows7-32 opt 40,545,390.40 -> 39,666,074.57
  2%  Resident Memory windows7-32 opt 335,134,154.79 -> 328,042,897.82
  2%  Resident Memory windows7-32 pgo 330,100,132.51 -> 323,492,765.97
  2%  Explicit Memory linux64 opt 329,870,473.39 -> 323,261,957.98

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=10996
You need to log in before you can comment on or make changes to this bug.