Valid url with http 200 return code redirects to localhost

VERIFIED DUPLICATE of bug 12748

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 12748
19 years ago
16 years ago

People

(Reporter: tor, Assigned: Gagan)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
The URL listed (which is the redirect you get from www.handspring.com)
is valid and returns a page without redirection from telnet and netscape.
mozilla instead redirects to localhost, but the URL bar still gives the
original IP.  This happens with both apprunner and viewer.  This is on
a 9/17 evening CVS pull.

Comment 1

19 years ago
This is the IP bug. The Lookup always returns ok and IPs are not really
resolved. It maps to localhost. A fix exists, but is currently not in the tree,
waiting for review ... see the attachement ...

Comment 2

19 years ago
Created attachment 1774 [details] [diff] [review]
patch for nsDnsService.cpp
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

19 years ago
*** This bug has been marked as a duplicate of 11204 ***

Comment 4

18 years ago
Bulk move of all Networking-Core (to be deleted component) bugs to new
Networking component.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
verified duplicate of 12748

Comment 6

17 years ago
+makingtest. This behavior did not happen on other platforms...
REOPEN:
correcint dupe.
Status: VERIFIED → REOPENED
Keywords: makingtest
Resolution: DUPLICATE → ---

Comment 7

17 years ago


*** This bug has been marked as a duplicate of 12748 ***
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.