Closed Bug 1424679 Opened 4 years ago Closed 4 years ago

Firefox can not correctly rendering 'NARROW NO-BREAK SPACE' (U+202F) on iOS(11.2).

Categories

(Firefox for iOS :: General, defect)

Unspecified
iOS
defect
Not set
critical

Tracking

()

RESOLVED INVALID
Tracking Status
fxios ? ---

People

(Reporter: siqinbilige, Unassigned)

Details

Attachments

(1 file)

Attached image 202f.jpg
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171206182557

Steps to reproduce:

Access Mongolian site http://www.mongolfont.com/mn/document/dj/dj024d.html.



Actual results:

The all words with 202F were broken.



Expected results:

The all words with 202F are rendered correctly.
This issue was happened before on Windows.
  https://bugzilla.mozilla.org/show_bug.cgi?id=1273154
May be, It was broken because of the Webkit.
  https://bugs.webkit.org/show_bug.cgi?id=172205
  Th 202F buggy many times on Webkit. In particular start with 202F.
There is a sample.
  http://www.mongolfont.com/test/firefox/202f.html
Severity: normal → critical
OS: Unspecified → iOS
Component: Untriaged → General
Product: Firefox → Firefox for iOS
Version: 57 Branch → unspecified
We will discuss this in the triage meeting.
tracking-fxios: --- → ?
I doubt there's anything we can realistically do about this in Firefox as long as we're dependent on webkit to render the content.
Does this properly work in other browsers on iOS? How about Safari?
Flags: needinfo?(siqinbilige)
(In reply to Stefan Arentz [:st3fan] from comment #4)
> Does this properly work in other browsers on iOS? How about Safari?

No.
Flags: needinfo?(siqinbilige)
If this is also happening in Safari, there is nothing we can do to fix it.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.