Closed Bug 1424944 Opened 3 years ago Closed 3 years ago

Crash in mozilla::dom::FetchDriverObserver::Release

Categories

(Core :: Audio/Video: MediaStreamGraph, defect, P2)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox59 --- affected

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-f5a76ef4-2371-403d-b9f2-8a7df0171207.
=============================================================

Seen while looking at nightly crash stats - crashes started in 59 using 20171206221407. 23 crashes/19 installs in 7 days: http://bit.ly/2yiYIVS

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b4cef8d1dff06a1ec2b9bb17211c0c3c7f5b76fa&tochange=99a3b09ac1898eb1db05430e2876d6643ba0d4a8

Top 10 frames of crashing thread:

0 xul.dll mozilla::dom::FetchDriverObserver::Release dom/fetch/FetchDriver.h:48
1 xul.dll mozilla::AudioChunk::~AudioChunk 
2 xul.dll nsTArray_Impl<mozilla::AudioChunk, nsTArrayInfallibleAllocator>::RemoveElementsAt xpcom/ds/nsTArray.h:2047
3 xul.dll mozilla::MediaSegmentBase<mozilla::AudioSegment, mozilla::AudioChunk>::RemoveLeading dom/media/MediaSegment.h:515
4 xul.dll mozilla::MediaSegmentBase<mozilla::AudioSegment, mozilla::AudioChunk>::ForgetUpTo dom/media/MediaSegment.h:281
5 xul.dll mozilla::StreamTracks::ForgetUpTo dom/media/StreamTracks.cpp:108
6 xul.dll mozilla::MediaStreamGraphImpl::UpdateCurrentTimeForStreams dom/media/MediaStreamGraph.cpp:353
7 xul.dll mozilla::MediaStreamGraphImpl::OneIteration dom/media/MediaStreamGraph.cpp:1496
8 xul.dll mozilla::AudioCallbackDriver::DataCallback dom/media/GraphDriver.cpp:979
9 xul.dll passthrough_resampler<float>::fill media/libcubeb/src/cubeb_resampler.cpp:76

=============================================================
FWIW, the FetchDriverObserver bit there looks like bad stack translation.  AFAICT this media code does not directly use fetch API.
Component: Audio/Video → Audio/Video: MediaStreamGraph
Paul - is the recent spike (ForgetUpTo(), etc) due to your backed-out landing?
Flags: needinfo?(padenot)
Yes. Relanding today with the fix.
Flags: needinfo?(padenot)
Rank: 15
Priority: -- → P2
Should this be closed now?
Flags: needinfo?(padenot)
I don't see any crashes on recent builds, so I'm closing per comment 3.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(padenot)
Resolution: --- → WORKSFORME
Fixed by backout of original landing of Bug 1397793
Blocks: 1397793
You need to log in before you can comment on or make changes to this bug.