Closed Bug 1425449 Opened 2 years ago Closed 2 years ago

The first and second New Tab don't have a favicon

Categories

(Firefox :: Theme, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Firefox 59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- fixed

People

(Reporter: mehmet.sahin, Assigned: johannh)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached video New_Tab_favicon.mov
59.0a1 (2017-12-15) (64-Bit)
macOS 10.12.6

STR:

1) Open a new window with three New Tabs

Actual: New Tab #1 and #2 don't have a favicon. But #3 has it.

Expected: All tabs should show it (or hide them at all)

A screencast is attached.

This seems to be recent regression from yesterdays build to today.

Thanks.
The first new tab is about:home. The second new tab is not preloaded.
Depends on: 1401955
Keywords: regression
Summary: Regression: The first and second New Tab don't have a favicon → The first and second New Tab don't have a favicon
Depends on: 1422074
Looks like the icon is first appearing then disappearing?
Sorry, in comment 1 I meant to clarify that the first tab about:home (never preloaded) and second tab is about:newtab (not preloaded). Subbsequent about:newtab opened after the first about:newtab should be preloaded.

So probably something about preloaded about:newtabs not triggering some code path that happens for "regular" page loads.?
(In reply to Ed Lee :Mardak from comment #2)
> Looks like the icon is first appearing then disappearing?

Yes, correct. It appears and disappears again.
johannh, I would guess from comment 3 that some default icon behavior is happening when the page loads "normally" (e.g., to clear the icon if a regular website doesn't have an icon ??). Preloaded pages are already loaded, so they don't trigger the usual progress listeners.
Blocks: 1401955, 1422074
No longer depends on: 1401955, 1422074
This will get fixed in bug 1422903.
Depends on: 1422903
Just only for your information: It seems that it does not happen only on the first and second new tab. The favicon also disappears, if you open some new tab quickly in succession.

A screencast is attached.

Thanks for looking into it.
Priority: -- → P2
Fixed by bug 1422903
https://hg.mozilla.org/mozilla-central/rev/a618b142d9dc
Assignee: nobody → jhofmann
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
I have reproduced this bug with Nightly 59.0a1 (2017-12-15) on Windows 10, 64 Bit!

This bug's fix is verified with latest Nightly!

Build ID   : 20180120100135
User Agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
QA Whiteboard: [bugday-20180117]
You need to log in before you can comment on or make changes to this bug.